<!DOCTYPE html><html class="no-js" lang="en" data-reactroot=""><head><meta charSet="utf-8"/><meta http-equiv="Accept-CH" content="DPR,Width,Viewport-Width"/><meta name="aol-te-auth" content="1c424580-0f86-4d9b-88b2-bc8c0d029d4c"/><meta name="blitz" content="mu-6e4ce5cd-57f20d11-7c0ecee9-d55c79e2"/><meta name="msvalidate.01" content="7A63840181953B2A5A1FEA25FB45A991"/><meta name="robots" content="NOODP,NOYDIR"/><meta name="verify-v1" content="+Ntj422Jc4V03qgBqLYbF3LMvrursV0X2btn2Zoqn9w="/><meta name="description" content="The  Baltimore Ravens   activated   Lamar Jackson  from the reserve/COVID-19 list on Monday, paving the way for him to start Tuesday against the  Dallas Cowboys ..."/><meta name="viewport" content="width=device-width, initial-scale=1"/><meta property="fb:app_id" content="135174055162"/><meta name="al:iphone:url" content="teamstream://article/bleacherreport.com/articles/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys"/><meta name="al:iphone:app_store_id" content="418075935"/><meta name="al:iphone:app_name" content="Bleacher Report"/><meta name="al:ipad:url" content="teamstream://article/bleacherreport.com/articles/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys"/><meta name="al:ipad:app_store_id" content="484725748"/><meta name="al:ipad:app_name" content="Bleacher Report"/><meta name="al:android:url" content="https://bleacherreport.com/articles/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys"/><meta name="al:android:app_name" content="Bleacher Report"/><meta name="al:android:package" content="com.bleacherreport.android.teamstream"/><meta name="al:web:url" content="https://bleacherreport.com/articles/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys"/><meta property="og:site_name" content="Bleacher Report"/><meta property="og:locale" content="en_US"/><meta name="p:domain_verify" content="0c768466449ebb550411234d6d4ffc30"/><meta name="theme-color" content="#000"/><meta name="twitter:app:name:iphone" content="Bleacher Report"/><meta name="twitter:app:id:iphone" content="418075935"/><meta name="twitter:app:name:ipad" content="Bleacher Report"/><meta name="twitter:app:id:ipad" content="484725748"/><meta name="twitter:app:name:googleplay" content="Bleacher Report"/><meta name="twitter:app:id:googleplay" content="com.bleacherreport.android.teamstream"/><meta name="twitter:widgets:new-embed-design" content="on"/><meta name="twitter:site" content="@bleacherreport"/><meta name="article:publisher" content="https://www.facebook.com/bleacherreport"/><meta name="author" content="Tyler Conway"/><meta property="og:description" content="The  Baltimore Ravens   activated   Lamar Jackson  from the reserve/COVID-19 list on Monday, paving the way for him to start Tuesday against the  Dallas Cowboys ..."/><meta property="og:image" content="https://img.bleacherreport.net/img/images/photos/003/895/027/hi-res-3e3cf5e8bee1bc70c737f7fd1cc31de2_crop_exact.jpg?w=1200&amp;h=1200&amp;q=75"/><meta property="og:title" content="Lamar Jackson Activated from COVID-19 List Ahead of Ravens vs. Cowboys"/><meta property="og:type" content="article"/><meta property="og:url" content="https://bleacherreport.com/articles/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys"/><meta name="pubdate" content="2020-12-07T16:02:48-05:00"/><meta name="thumbnail" content="https://img.bleacherreport.net/img/images/photos/003/895/027/hi-res-3e3cf5e8bee1bc70c737f7fd1cc31de2_crop_exact.jpg?w=1200&amp;h=1200&amp;q=75"/><meta name="twitter:app:url:googleplay" content="https://bleacherreport.com/articles/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys"/><meta name="twitter:app:url:ipad" content="teamstream://article/bleacherreport.com/articles/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys"/><meta name="twitter:app:url:iphone" content="teamstream://article/bleacherreport.com/articles/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:description" content="The  Baltimore Ravens   activated   Lamar Jackson  from the reserve/COVID-19 list on Monday, paving the way for him to start Tuesday against the  Dallas Cowboys ..."/><meta name="twitter:image" content="https://img.bleacherreport.net/img/images/photos/003/895/027/hi-res-3e3cf5e8bee1bc70c737f7fd1cc31de2_crop_exact.jpg?w=1200&amp;h=1200&amp;q=75"/><meta name="twitter:title" content="Lamar Jackson Activated from COVID-19 List Ahead of Ravens vs. Cowboys"/><meta name="twitter:url" content="https://bleacherreport.com/articles/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys"/><link rel="shortcut icon" href="https://static-assets.bleacherreport.net/favicon.ico"/><title>Lamar Jackson Activated from COVID-19 List Ahead of Ravens vs. Cowboys | Bleacher Report | Latest News, Videos and Highlights</title><script src="//d1je72vo6cxqo9.cloudfront.net/script.js" async="" id="rwxsawuta"></script><script type="text/javascript">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</script><link rel="stylesheet" type="text/css" href="https://static-assets.bleacherreport.net/css/articlePage.critical.60ec65283706f31ae8b2.css" crossorigin="anonymous" class="" media="all"/><link rel="stylesheet" type="text/css" href="https://static-assets.bleacherreport.net/css/global.8aefdeea8655b03ee786.css" crossorigin="anonymous" class="preload-css" media="print"/><link rel="stylesheet" type="text/css" href="https://static-assets.bleacherreport.net/css/atomic.d0db47305469336518c3.css" crossorigin="anonymous" class="preload-css" media="print"/><link rel="stylesheet" type="text/css" href="https://cdn.bitmovin.com/player/web/8.10.1/bitmovinplayer-ui.css" crossorigin="anonymous" class="" media="all"/><script src="//d1je72vo6cxqo9.cloudfront.net/script.js" async="" id="rwxsawuta"></script><script src="https://static-assets.bleacherreport.net/js/registerServiceWorker.js" async="" id="registerServiceWorkerJS"></script><script type="application/ld+json">{"@context":"http://schema.org","@type":"NewsArticle","about":"The  Baltimore Ravens   activated   Lamar Jackson  from the reserve/COVID-19 list on Monday, paving the way for him to start Tuesday against the  Dallas Cowboys ...","author":{"@type":"Person","name":"Tyler Conway","jobTitle":"Featured Columnist"},"dateModified":"2020-12-07T16:11:28-05:00","datePublished":"2020-12-07T16:02:48-05:00","description":"The  Baltimore Ravens   activated   Lamar Jackson  from the reserve/COVID-19 list on Monday, paving the way for him to start Tuesday against the  Dallas Cowboys ...","headline":"Lamar Jackson Activated from COVID-19 List Ahead of Ravens vs. Cowboys","image":{"type":"ImageObject","url":"https://img.bleacherreport.net/img/images/photos/003/895/027/hi-res-3e3cf5e8bee1bc70c737f7fd1cc31de2_crop_exact.jpg?w=900&h=600&q=75"},"inLanguage":"English","isFamilyFriendly":true,"keywords":"NFL,Baltimore_Ravens,Breaking_News,Lamar_Jackson,BNT_NFL","mainEntityOfPage":"The  Baltimore Ravens   activated   Lamar Jackson  from the reserve/COVID-19 list on Monday, paving the way for him to start Tuesday against the  Dallas Cowboys ...","publisher":{"@type":"Organization","name":"Bleacher Report","url":"https://bleacherreport.com","logo":{"type":"ImageObject","url":"https://static-assets.bleacherreport.net/img/br_60_height.png","width":"80","height":"60"}},"thumbnailURL":"https://img.bleacherreport.net/img/images/photos/003/895/027/hi-res-3e3cf5e8bee1bc70c737f7fd1cc31de2_crop_exact.jpg?w=900&h=600&q=75"}</script><script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://bleacherreport.com","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https://bleacherreport.com/baltimore-ravens","name":"Baltimore Ravens"}},{"@type":"ListItem","position":3,"item":{"@id":"https://bleacherreport.com/articles/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys","name":"Lamar Jackson Activated from COVID-19 List Ahead of Ravens vs. Cowboys"}}]}</script><link rel="manifest" type="" href="/manifest.json" crossorigin="anonymous" class="" media="all"/><link rel="mask-icon" type="" href="/img/favicon/safariMaskIcon.svg" color="#000000" crossorigin="anonymous" class="" media="all"/><link rel="apple-touch-icon" type="" href="/img/favicon/appleTouchIcon.png" sizes="180x180" crossorigin="anonymous" class="" media="all"/><link rel="icon" type="" href="/img/favicon/favicon32.png" sizes="32x32" crossorigin="anonymous" class="" media="all"/><link rel="icon" type="" href="/img/favicon/favicon16.png" sizes="16x16" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://ib.adnxs.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://prebid.adnxs.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://secure.adnxs.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://fastlane.rubiconproject.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://optimized-by.rubiconproject.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://ads.rubiconproject.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://fastlane-adv.rubiconproject.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://aax.amazon-adsystem.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://c.amazon-adsystem.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://bidder.criteo.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://static.criteo.net" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://js-sec.indexww.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://as-sec.casalemedia.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://observe.aniview.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://mcdp-chidc2.outbrain.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://log.outbrainimg.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://videoclientsservicescalls.outbrain.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://e.infogr.am" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://serv.vid-play.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://servt.vid-play.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://track.aniview.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://pistyll.bleacherreport.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://geo.moatads.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://preferences.truste.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://vis.vi-serve.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://t.vi-serve.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://s.vi-serve.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://secure-us.imrworldwide.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://www.facebook.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://connect.facebook.net" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://pixel.adsafeprotected.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://www.instagram.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://platform.instagram.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://tags.tiqcdn.com" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/proxima-nova/proxima-nova-regular.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/proxima-nova/proxima-nova-regular-italic.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/proxima-nova/proxima-nova-medium.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/proxima-nova/proxima-nova-bold.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/effra/effra-regular.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/effra/effra-medium.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/effra/effra-bold.woff2" crossorigin="anonymous" class="" media="all"/><link rel="amphtml" type="" href="https://syndication.bleacherreport.com/amp/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys.amp.html" crossorigin="anonymous" class="" media="all"/><link rel="alternate" type="" href="android-app://com.bleacherreport.android.teamstream/http/bleacherreport.com/articles/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys" crossorigin="anonymous" class="" media="all"/><link rel="alternate" type="" href="android-app://com.bleacherreport.android.teamstream/teamstream/article/bleacherreport.com/articles/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys" crossorigin="anonymous" class="" media="all"/><link rel="alternate" type="" href="ios-app://418075935/http/bleacherreport.com/articles/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys" crossorigin="anonymous" class="" media="all"/><link rel="canonical" type="" href="https://bleacherreport.com/articles/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys" crossorigin="anonymous" class="" media="all"/><link rel="alternate" type="application/json+oembed" href="https://embeder.bleacherreport.com/oembed?url=https%3A%2F%2Fbleacherreport.com%2Farticles%2F2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys" crossorigin="anonymous" class="" media="all"/></head><body><div id="app"><div class="template website light"><div class="fixedRegion"><div class="fixedBottom"></div></div><header><div class="nav organism"><a id="br-logo" class="siteLogo" href="/"><svg class="atom logo svg br" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 1600 1200"><title>Bleacher Report Logo</title><g><path d="M484.85 200H200v800h284.85L600 884.85v-229.7L544.85 600 600 544.85v-229.7zM320 540V320h115.15L480 364.85v130.3L435.15 540zm115.15 120L480 704.85v130.3L435.15 880H320V660zM1415 1000l-99.35-370.79 84.35-84.36v-229.7L1284.85 200H1000v800h120V660h83.9l91.1 340zm-295-680h115.15l44.85 44.85v130.3L1235.15 540H1120zM700 770.71l200-200V429.29l-200 200v141.42z"></path></g></svg></a><nav id="league-links"><ol class="molecule nav-list"><li class="atom nav-link parent-link top-level" id="nfl"><a href="/nfl">NFL</a></li><li class="atom nav-link parent-link top-level" id="nba"><a href="/nba">NBA</a></li><li class="atom nav-link parent-link top-level" id="college-football"><a href="/college-football">CFB</a></li><li class="atom nav-link parent-link top-level" id="world-football"><a href="/world-football">World Football</a></li><li class="atom nav-link parent-link top-level" id="mlb"><a href="/mlb">MLB</a></li><li class="atom nav-link parent-link top-level" id="nhl"><a href="/nhl">NHL</a></li><li class="atom nav-link parent-link top-level" id="college-basketball"><a href="/college-basketball">CBB</a></li><li class="atom nav-link top-level" id="mma"><a href="/mma">MMA</a></li><li class="atom nav-link top-level" id="all-elite-wrestling"><a href="/all-elite-wrestling">AEW</a></li><li class="atom nav-link top-level" id="wwe"><a href="/wwe">WWE</a></li><li class="atom nav-link top-level" id="wnba"><a href="/wnba">WNBA</a></li><li class="atom nav-link top-level" id="golf"><a href="/golf">Golf</a></li><li class="atom nav-link top-level" id="tennis"><a href="/tennis">Tennis</a></li><li class="atom nav-link top-level" id="boxing"><a href="/boxing">Boxing</a></li><li class="atom nav-link top-level" id="https://bleacherreportshop.com/?utm_source=Bleacher%20Report&amp;utm_medium=referral&amp;utm_campaign=Bleacher%20Report%20Website%20Menu"><a href="https://bleacherreportshop.com/?utm_source=Bleacher%20Report&amp;utm_medium=referral&amp;utm_campaign=Bleacher%20Report%20Website%20Menu">B/R Shop</a></li><li class="atom nav-link parent-link top-level" id="more"><span>More</span></li></ol></nav><nav id="non-league-links"><ol class="molecule nav-list"><li class="atom nav-link parent-link top-level" id="shows"><span>Shows</span></li><li class="atom nav-link top-level" id="kicks"><a href="/kicks">B/R Kicks</a></li><li class="atom nav-link top-level" id="https://live.bleacherreport.com?utm_source=Website&amp;utm_medium=BleacherReport&amp;utm_campaign=brws-General-topnav"><a href="https://live.bleacherreport.com?utm_source=Website&amp;utm_medium=BleacherReport&amp;utm_campaign=brws-General-topnav">B/R Live</a></li><li class="atom nav-link top-level" id="https://bleacherreport.com/br-mag"><a href="https://bleacherreport.com/br-mag">Mag</a></li><li class="atom nav-link top-level" id="mobile"><a href="/mobile">Get the App</a></li><li class="atom nav-link top-level" id="https://bleacherreportshop.com/?utm_source=Bleacher%20Report&amp;utm_medium=referral&amp;utm_campaign=Bleacher%20Report%20Website%20Menu"><a href="https://bleacherreportshop.com/?utm_source=Bleacher%20Report&amp;utm_medium=referral&amp;utm_campaign=Bleacher%20Report%20Website%20Menu">B/R Shop</a></li></ol></nav><div class="tools-container"><ul class="userTools molecule"><li class="molecule userMenu"><img src="https://static-assets.bleacherreport.net/img/molecules/nav/flagUSGray.png" alt="content has been localized for visitors from the United States" class="flag"/>Account<div class="dropdown"><ul><li><a href="/sign_up" class="sign-up">Sign Up</a></li><li><a href="/sign_in" class="login">Login</a></li></ul><div class="dropdown-header">Edition</div><div class="atom dropdown-body"><ul class="edition-flags"><li><a class="selected" href="/us"><img src="https://static-assets.bleacherreport.net/img/molecules/nav/flagUS.png" alt="United States of America flag"/></a></li><li><a class="" href="/uk"><img src="https://static-assets.bleacherreport.net/img/molecules/nav/flagUK.png" alt="Great Britain flag"/></a></li></ul></div></div></li></ul></div></div></header><div class="atom score-card-carousel"><div class="react-multi-carousel-list  "><ul class="react-multi-carousel-track slider" style="transition:none;overflow:unset;transform:translate3d(0px,0,0)"></ul></div></div><div id="outer-container" class=""><div class="ad"><div class="br-ad-wrapper atom advert"><div id="br-ad-5" class="br-ad" data-collapsed="0" data-country="US" data-position="oop_skin_01" data-reload="1" data-responsive-size="[[[970,0],[[3,3]]],[[0,0],[]]]" data-size="[[3,3]]"></div></div></div><div class="ad"><div class="br-ad-wrapper atom advert"><div id="br-ad-1" class="br-ad" data-collapsed="0" data-country="US" data-position="bnr_atf_01" data-reload="2" data-responsive-size="[[[1280,0],[&quot;fluid&quot;,[1280,100],[970,250],[970,66],[728,90]]],[[970,0],[&quot;fluid&quot;,[970,250],[970,66],[728,90]]],[[728,0],[&quot;fluid&quot;,[728,90],[300,100],[320,50]]],[[0,0],[&quot;fluid&quot;,[300,100],[320,50]]]]" data-size="[[320,50],[320,1]]"></div></div></div><div id="main-content"><div id="ad-skin-measurability-l" class="ad-rail"></div><article class="page articlePage"><header><div class="atom share"><ul><li class="shareFacebook" title="Share this article on Facebook"><svg class="atom icon svg facebook" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 10 16"><title>Facebook Logo</title><path d="M6.24 16V8.7h2.45l.365-2.842H6.24V4.04c0-.822.227-1.384 1.41-1.384h1.5V.112C8.42.035 7.686-.002 6.953 0 4.79 0 3.3 1.325 3.3 3.76v2.098H.846V8.7H3.3V16h2.94z"></path></svg></li><li class="shareTwitter" title="Share this article on Twitter"><svg class="atom icon svg twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 14"><title>Twitter Logo</title><path d="M5.042 13.504c6.01 0 9.3-4.985 9.3-9.3 0-.14 0-.28-.006-.42.638-.46 1.192-1.04 1.632-1.697-.586.262-1.217.434-1.88.517.675-.402 1.192-1.046 1.44-1.81-.63.375-1.332.643-2.078.79C12.85.946 12.003.55 11.066.55c-1.804 0-3.27 1.467-3.27 3.27 0 .256.032.505.083.747-2.717-.134-5.126-1.44-6.74-3.417C.86 1.635.7 2.196.7 2.795c0 1.134.58 2.135 1.455 2.722-.536-.02-1.04-.166-1.48-.408v.043c0 1.58 1.13 2.907 2.62 3.207-.273.076-.56.115-.86.115-.21 0-.414-.02-.612-.058.414 1.3 1.626 2.244 3.053 2.27-1.12.88-2.53 1.402-4.06 1.402-.26 0-.523-.014-.778-.046 1.44.918 3.162 1.46 5.004 1.46"></path></svg></li><li class="shareLink" title="Copy this link to your clipboard"><svg class="atom icon svg link" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20 10"><title>Copy Link Icon</title><path d="M1.9 5c0-1.71 1.39-3.1 3.1-3.1h4V0H5C2.24 0 0 2.24 0 5s2.24 5 5 5h4V8.1H5C3.29 8.1 1.9 6.71 1.9 5zM6 6h8V4H6v2zm9-6h-4v1.9h4c1.71 0 3.1 1.39 3.1 3.1 0 1.71-1.39 3.1-3.1 3.1h-4V10h4c2.76 0 5-2.24 5-5s-2.24-5-5-5z"></path></svg></li></ul></div><button class="atom button" type="button"><a class="atom tagLink" href="/baltimore-ravens"><div class="imgWrapper"><img src="https://cdn.bleacherreport.net/images/team_logos/328x328/baltimore_ravens.png" alt="Baltimore Ravens logo"/></div><span class="teamAvatar__name">Baltimore Ravens</span></a></button><h1>Lamar Jackson Activated from COVID-19 List Ahead of Ravens vs. Cowboys</h1><span class="atom authorInfo"><a href="/users/292151" rel="noopener noreferrer"><span class="name">Tyler Conway</span></a><a class="twitterHandle" rel="noopener noreferrer" target="_blank" href="http://twitter.com/jtylerconway"><span>@<!-- -->jtylerconway</span><svg class="atom icon svg twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 14"><title>Twitter Logo</title><path d="M5.042 13.504c6.01 0 9.3-4.985 9.3-9.3 0-.14 0-.28-.006-.42.638-.46 1.192-1.04 1.632-1.697-.586.262-1.217.434-1.88.517.675-.402 1.192-1.046 1.44-1.81-.63.375-1.332.643-2.078.79C12.85.946 12.003.55 11.066.55c-1.804 0-3.27 1.467-3.27 3.27 0 .256.032.505.083.747-2.717-.134-5.126-1.44-6.74-3.417C.86 1.635.7 2.196.7 2.795c0 1.134.58 2.135 1.455 2.722-.536-.02-1.04-.166-1.48-.408v.043c0 1.58 1.13 2.907 2.62 3.207-.273.076-.56.115-.86.115-.21 0-.414-.02-.612-.058.414 1.3 1.626 2.244 3.053 2.27-1.12.88-2.53 1.402-4.06 1.402-.26 0-.523-.014-.778-.046 1.44.918 3.162 1.46 5.004 1.46"></path></svg></a><span class="title">Featured Columnist</span></span><span class="date">December 7, 2020</span><button class="atom button commentCount" type="button"><span class="label"> <!-- -->Comments</span><svg class="atom icon svg commentBubble" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20 20"><title>Comment Bubble Icon</title><path d="M2 0h16c1.1 0 2 .9 2 2v18l-4-4H2c-1.1 0-2-.9-2-2V2C0 .9.9 0 2 0z"></path></svg></button></header><div class="molecule alert-banner"><svg xmlns="http://www.w3.org/2000/svg" class="atom alert-icon" width="25" height="29" viewBox="0 0 25 29"><g fill="none" fill-rule="evenodd" transform="translate(0 1)"><path fill="#000" d="M13.618 25.966c0 1.124-.877 2.034-1.958 2.034s-1.957-.91-1.957-2.034zM11.667 0c1.128.004 2.043.956 2.043 2.128v.476c3.946.959 6.89 4.63 6.89 9.024h-.013v4.877c.011 2.449.143 1.582 1.806 3.31.288.32.94 1.12.94 2.55 0 .923-.418 2.401-1.166 2.401h-21C.419 24.766 0 23.288 0 22.365c0-1.43.652-2.23.942-2.55 1.71-1.778 1.8-.81 1.805-3.529v-4.658h-.014c0-4.394 2.944-8.065 6.89-9.024v-.476C9.624.955 10.54.003 11.668 0z"></path><circle cx="19" cy="5" r="5.5" fill="#03FC96" stroke="#FAFAFA"></circle></g></svg><div><span class="alert-banner__text">Alerted <!-- -->3h<!-- --> ago in the </span><a class="alert-banner__install-link">B/R App</a></div></div><div class="organism contentStream"><div><div class="atom photo" itemscope="" itemType="http://schema.org/ImageObject"><p></p><div class="imgWrapper"><div class="atom lazyImage"><img alt="Lamar Jackson, quarterback de los Ravens de Baltimore, acarrea el balÃ³n en el partido del domingo 22 de noviembre ante los Titans de Tennessee (AP Foto/Gail Burton)" src="https://static-assets.bleacherreport.net/img/atoms/lazyImage/logo.png"/></div></div><small><span class="caption"></span><span itemProp="citation" class="credit">Gail Burton/Associated Press</span></small></div><p class="">The <a href="http://bleacherreport.com/baltimore-ravens">Baltimore Ravens</a> <a href="https://twitter.com/Ravens/status/1336052770412093441" target="_blank" rel="noopener noreferrer">activated</a> <a href="http://bleacherreport.com/lamar-jackson">Lamar Jackson</a> from the reserve/COVID-19 list on Monday, paving the way for him to start Tuesday against the <a href="http://bleacherreport.com/dallas-cowboys">Dallas Cowboys</a>.</p><p class="">Jackson missed last Wednesday's game against the <a href="http://bleacherreport.com/pittsburgh-steelers">Pittsburgh Steelers</a> after being placed on the COVID-19 list. <a href="http://bleacherreport.com/robert-griffin">Robert Griffin III</a> played in Jackson's stead, with Trace McSorley coming in late in the fourth quarter after Griffin suffered a hamstring injury.</p><p class="">Jackson was not eligible to be taken off the reserve list until Sunday, so the Tuesday kickoff played into the Ravens' favor. He has remained part of virtual meetings with the team while quarantined. </p><p class="">"He's really lockstep, each and every step through," offensive coordinator Greg Roman <a href="https://www.espn.com/nfl/story/_/id/30461769/source-baltimore-ravens-qb-lamar-jackson-expected-start-vs-dallas-cowboys" target="_blank" rel="noopener noreferrer">told reporters</a> Sunday. "The only thing he can't do is, obviously, be here at the facility and actually take part in it. But, mentally, he's right on it."</p><div class="ad"><div class="lazy br-ad-wrapper atom advert"><div id="br-ad-17006701" class="br-ad-lazy" data-collapsed="0" data-country="US" data-position="rect_atf_01" data-reload="1" data-responsive-size="[[[970,0],[&quot;fluid&quot;,[970,250],[970,66],[728,90],[300,250]]],[[728,0],[&quot;fluid&quot;,[728,90],[300,250]]],[[0,0],[&quot;fluid&quot;,[300,250],[320,50]]]]" data-size="[[300,600],[300,250],[300,2]]"></div></div></div><p class="">Baltimore is currently on a three-game losing streak, dropping to 6-5 and sitting on the outside looking in of the AFC playoff picture.</p><p class="">Jackson's return will be a significant boost given McSorley is their only other option under center with Griffin on injured reserve. McSorley is an excellent athlete at the position but is a boom-or-bust proposition as a passer.</p><p class="">Jackson hasn't performed at his MVP level from a year ago but remains one of the most dynamic playmakers in the sport. He's thrown for 1,948 yards and 15 touchdowns against six interceptions, adding 575 yards and three touchdowns as a rusher. </p><div class="molecule nr-video-manager"><div><a rel="noopener noreferrer" target="_blank" class="molecule thumbnail"><div class="atom lazyImage"><img alt="" src="https://static-assets.bleacherreport.net/img/atoms/lazyImage/logo.png"/></div><svg class="atom icon svg videoPlay" xmlns="http://www.w3.org/2000/svg" viewBox="1 0 59 60"><title>Video Play Button</title><path d="M30.5 0C13.932 0 .5 13.43.5 30s13.432 30 30 30c16.57 0 30-13.43 30-30S47.07 0 30.5 0zm0 54c-13.233 0-24-10.766-24-24s10.767-24 24-24c13.234 0 24 10.766 24 24s-10.766 24-24 24zm-7.274-32.4v16.8c0 2.31 1.637 3.255 3.638 2.1l14.549-8.4c2-1.155 2-3.045 0-4.2l-14.55-8.4c-2-1.155-3.637-.21-3.637 2.1z"></path></svg></a><div class="atom video-indicator"><span class="text">Videos you might like </span> </div></div></div></div></div><div class="footer-wrapper"><footer><div class="atom share"><ul><li class="shareFacebook" title="Share this article on Facebook"><svg class="atom icon svg facebook" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 10 16"><title>Facebook Logo</title><path d="M6.24 16V8.7h2.45l.365-2.842H6.24V4.04c0-.822.227-1.384 1.41-1.384h1.5V.112C8.42.035 7.686-.002 6.953 0 4.79 0 3.3 1.325 3.3 3.76v2.098H.846V8.7H3.3V16h2.94z"></path></svg></li><li class="shareTwitter" title="Share this article on Twitter"><svg class="atom icon svg twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 14"><title>Twitter Logo</title><path d="M5.042 13.504c6.01 0 9.3-4.985 9.3-9.3 0-.14 0-.28-.006-.42.638-.46 1.192-1.04 1.632-1.697-.586.262-1.217.434-1.88.517.675-.402 1.192-1.046 1.44-1.81-.63.375-1.332.643-2.078.79C12.85.946 12.003.55 11.066.55c-1.804 0-3.27 1.467-3.27 3.27 0 .256.032.505.083.747-2.717-.134-5.126-1.44-6.74-3.417C.86 1.635.7 2.196.7 2.795c0 1.134.58 2.135 1.455 2.722-.536-.02-1.04-.166-1.48-.408v.043c0 1.58 1.13 2.907 2.62 3.207-.273.076-.56.115-.86.115-.21 0-.414-.02-.612-.058.414 1.3 1.626 2.244 3.053 2.27-1.12.88-2.53 1.402-4.06 1.402-.26 0-.523-.014-.778-.046 1.44.918 3.162 1.46 5.004 1.46"></path></svg></li><li class="shareLink" title="Copy this link to your clipboard"><svg class="atom icon svg link" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20 10"><title>Copy Link Icon</title><path d="M1.9 5c0-1.71 1.39-3.1 3.1-3.1h4V0H5C2.24 0 0 2.24 0 5s2.24 5 5 5h4V8.1H5C3.29 8.1 1.9 6.71 1.9 5zM6 6h8V4H6v2zm9-6h-4v1.9h4c1.71 0 3.1 1.39 3.1 3.1 0 1.71-1.39 3.1-3.1 3.1h-4V10h4c2.76 0 5-2.24 5-5s-2.24-5-5-5z"></path></svg></li></ul></div><div></div></footer><div class="atom relatedContent offscreen"><div class="title">Related</div><div class="organism contentStream"><ol><div class="cell articleSummary" data-article-id="6535867730"><div class="atom commentary"><h3>Ravens Activate Lamar Jackson</h3><p>Baltimore QB comes off the reserve/COVID-19 list ahead of Tuesday&#x27;s game vs. Cowboys</p></div><div class="articleMedia"><a href="https://bleacherreport.com/articles/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys" rel="" target="_self" class="molecule thumbnail"><div class="atom lazyImage"><img alt="Ravens Activate Lamar Jackson" src="https://static-assets.bleacherreport.net/img/atoms/lazyImage/logo.png"/></div></a></div><div class="articleContent"><a class="atom tagLink" href="/baltimore-ravens"><div class="imgWrapper"><img src="https://cdn.bleacherreport.net/images/team_logos/328x328/baltimore_ravens.png" alt="Baltimore Ravens logo"/></div><span class="teamAvatar__name">Baltimore Ravens</span></a><a class="atom articleTitle" href="https://bleacherreport.com/articles/2921147-lamar-jackson-activated-from-covid-19-list-ahead-of-ravens-vs-cowboys" target="_self" rel=""><h3>Ravens Activate Lamar Jackson</h3></a><span class="atom authorInfo"><a class="authorPhoto" href="/users/undefined"><svg class="atom icon svg defaultUser" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 100 100"><circle cx="50" cy="50" r="50"></circle><g fill="#FFF" transform="translate(20 15)"><path d="M0 60.617C7.165 69.407 17.945 75 30 75s22.835-5.593 30-14.383C54.197 51.31 42.938 45 30 45 17.062 45 5.803 51.31 0 60.617z"></path><circle cx="30" cy="20" r="20"></circle></g></svg></a><a href="/users/undefined" rel="noopener noreferrer"><span class="name">Tyler Conway</span></a></span></div><span class="provider">via Bleacher Report</span></div><div class="cell articleSummary" data-article-id="6535854393"><div class="atom commentary"><h3>No Chargers HC Change Imminent</h3><p>LAC has &#x27;tremendous&#x27; respect for Anthony Lynn and would prefer to evaluate everything at the end of the year (Rapoport)</p></div><div class="articleMedia"><a href="https://bleacherreport.com/articles/2921328-report-anthony-lynns-firing-as-chargers-hc-not-imminent-after-patriots-loss" rel="" target="_self" class="molecule thumbnail"><div class="atom lazyImage"><img alt="No Chargers HC Change Imminent" src="https://static-assets.bleacherreport.net/img/atoms/lazyImage/logo.png"/></div></a></div><div class="articleContent"><a class="atom tagLink" href="/nfl"><div class="imgWrapper"><img src="https://cdn.bleacherreport.net/images/team_logos/328x328/nfl.png" alt="NFL logo"/></div><span class="teamAvatar__name">NFL</span></a><a class="atom articleTitle" href="https://bleacherreport.com/articles/2921328-report-anthony-lynns-firing-as-chargers-hc-not-imminent-after-patriots-loss" target="_self" rel=""><h3>No Chargers HC Change Imminent</h3></a><span class="atom authorInfo"><a class="authorPhoto" href="/users/undefined"><svg class="atom icon svg defaultUser" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 100 100"><circle cx="50" cy="50" r="50"></circle><g fill="#FFF" transform="translate(20 15)"><path d="M0 60.617C7.165 69.407 17.945 75 30 75s22.835-5.593 30-14.383C54.197 51.31 42.938 45 30 45 17.062 45 5.803 51.31 0 60.617z"></path><circle cx="30" cy="20" r="20"></circle></g></svg></a><a href="/users/undefined" rel="noopener noreferrer"><span class="name">Tyler Conway</span></a></span></div><span class="provider">via Bleacher Report</span></div><div class="cell articleSummary" data-article-id="6535842483"><div class="atom commentary"><h3>Former Bengals, Raiders LB Vontaze Burfict Arrested on Battery Charge</h3></div><div class="articleMedia"><a href="https://bleacherreport.com/articles/2921318-former-bengals-raiders-lb-vontaze-burfict-arrested-on-battery-charge" rel="" target="_self" class="molecule thumbnail"><div class="atom lazyImage"><img alt="Former Bengals, Raiders LB Vontaze Burfict Arrested on Battery Charge" src="https://static-assets.bleacherreport.net/img/atoms/lazyImage/logo.png"/></div></a></div><div class="articleContent"><a class="atom tagLink" href="/nfl"><div class="imgWrapper"><img src="https://cdn.bleacherreport.net/images/team_logos/328x328/nfl.png" alt="NFL logo"/></div><span class="teamAvatar__name">NFL</span></a><a class="atom articleTitle lowerMargin" href="https://bleacherreport.com/articles/2921318-former-bengals-raiders-lb-vontaze-burfict-arrested-on-battery-charge" target="_self" rel=""><h3>Former Bengals, Raiders LB Vontaze Burfict Arrested on Battery Charge</h3></a><span class="atom authorInfo"><a class="authorPhoto" href="/users/undefined"><svg class="atom icon svg defaultUser" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 100 100"><circle cx="50" cy="50" r="50"></circle><g fill="#FFF" transform="translate(20 15)"><path d="M0 60.617C7.165 69.407 17.945 75 30 75s22.835-5.593 30-14.383C54.197 51.31 42.938 45 30 45 17.062 45 5.803 51.31 0 60.617z"></path><circle cx="30" cy="20" r="20"></circle></g></svg></a><a href="/users/undefined" rel="noopener noreferrer"><span class="name">Rob Goldberg</span></a></span></div><span class="provider">via Bleacher Report</span></div><div class="cell articleSummary" data-article-id="6535834664"><div class="atom commentary"><h3>Bettor Hits Parlay on 1st Try</h3><p>New DraftKings bettor turned $2 into over $24K on a nine-team parlay with their very first bet 🤯</p></div><div class="articleMedia"><a href="https://bleacherreport.com/articles/2921323-bettor-wins-2470707-on-1st-ever-wager-bet-2-on-9-team-nfl-parlay" rel="" target="_self" class="molecule thumbnail"><div class="atom lazyImage"><img alt="Bettor Hits Parlay on 1st Try" src="https://static-assets.bleacherreport.net/img/atoms/lazyImage/logo.png"/></div></a></div><div class="articleContent"><a class="atom tagLink" href="/nfl"><div class="imgWrapper"><img src="https://cdn.bleacherreport.net/images/team_logos/328x328/nfl.png" alt="NFL logo"/></div><span class="teamAvatar__name">NFL</span></a><a class="atom articleTitle" href="https://bleacherreport.com/articles/2921323-bettor-wins-2470707-on-1st-ever-wager-bet-2-on-9-team-nfl-parlay" target="_self" rel=""><h3>Bettor Hits Parlay on 1st Try</h3></a><span class="atom authorInfo"><a class="authorPhoto" href="/users/undefined"><svg class="atom icon svg defaultUser" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 100 100"><circle cx="50" cy="50" r="50"></circle><g fill="#FFF" transform="translate(20 15)"><path d="M0 60.617C7.165 69.407 17.945 75 30 75s22.835-5.593 30-14.383C54.197 51.31 42.938 45 30 45 17.062 45 5.803 51.31 0 60.617z"></path><circle cx="30" cy="20" r="20"></circle></g></svg></a><a href="/users/undefined" rel="noopener noreferrer"><span class="name">Rob Goldberg</span></a></span></div><span class="provider">via Bleacher Report</span></div></ol></div></div><div class="atom outbrain OUTBRAIN" data-src="https://bleacherreport.com/articles/2921147" data-widget-id="AR_8" data-ob-template="BleacherReport_1"></div></div></article><div id="ad-skin-measurability-r" class="ad-rail"></div></div><div class="adsContainer"></div><footer class="molecule footer"><div><svg class="atom logo svg brPlateLight" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 1600 1200"><title>Bleacher Report Logo</title><g><rect width="1600" height="1200" fill="#fff"></rect><path fill="#000" d="M484.85 200H200v800h284.85L600 884.85v-229.7L544.85 600 600 544.85v-229.7zM320 540V320h115.15L480 364.85v130.3L435.15 540zm115.15 120L480 704.85v130.3L435.15 880H320V660zM1415 1000l-99.35-370.79 84.35-84.36v-229.7L1284.85 200H1000v800h120V660h83.9l91.1 340zm-295-680h115.15l44.85 44.85v130.3L1235.15 540H1120zM700 770.71l200-200V429.29l-200 200v141.42z"></path></g></svg><ul class="social"><li><a href="https://facebook.com/bleacherreport/"><svg class="atom icon svg facebookFilled" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 267 267"><title>Facebook Logo</title><path d="M252.16,0H14.73A14.73,14.73,0,0,0,0,14.73V252.16a14.73,14.73,0,0,0,14.73,14.73H142.56V163.54H107.78V123.26h34.78V93.55c0-34.47,21.05-53.24,51.81-53.24a285.37,285.37,0,0,1,31.08,1.59v36H204.12c-16.72,0-20,7.95-20,19.61v25.72H224l-5.19,40.28H184.15V266.89h68a14.73,14.73,0,0,0,14.73-14.73V14.73A14.73,14.73,0,0,0,252.16,0Z"></path></svg></a></li><li><a href="https://twitter.com/bleacherreport/"><svg class="atom icon svg twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 14"><title>Twitter Logo</title><path d="M5.042 13.504c6.01 0 9.3-4.985 9.3-9.3 0-.14 0-.28-.006-.42.638-.46 1.192-1.04 1.632-1.697-.586.262-1.217.434-1.88.517.675-.402 1.192-1.046 1.44-1.81-.63.375-1.332.643-2.078.79C12.85.946 12.003.55 11.066.55c-1.804 0-3.27 1.467-3.27 3.27 0 .256.032.505.083.747-2.717-.134-5.126-1.44-6.74-3.417C.86 1.635.7 2.196.7 2.795c0 1.134.58 2.135 1.455 2.722-.536-.02-1.04-.166-1.48-.408v.043c0 1.58 1.13 2.907 2.62 3.207-.273.076-.56.115-.86.115-.21 0-.414-.02-.612-.058.414 1.3 1.626 2.244 3.053 2.27-1.12.88-2.53 1.402-4.06 1.402-.26 0-.523-.014-.778-.046 1.44.918 3.162 1.46 5.004 1.46"></path></svg></a></li><li><a href="https://instagram.com/bleacherreport/"><svg class="atom icon svg instagram" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><title>Instagram Logo</title><g><path d="M11.816 5.744c-3.353 0-6.072 2.72-6.072 6.072 0 3.353 2.72 6.072 6.072 6.072 3.353 0 6.072-2.72 6.072-6.072 0-1.61-.64-3.155-1.778-4.294-1.14-1.138-2.684-1.778-4.294-1.778zm0 10.016c-2.178 0-3.944-1.766-3.944-3.944s1.766-3.944 3.944-3.944 3.944 1.766 3.944 3.944-1.766 3.944-3.944 3.944z"></path><circle cx="18.128" cy="5.52" r="1.416"></circle><path d="M23.024 4.08c-.614-1.587-1.87-2.842-3.456-3.456-.92-.345-1.89-.532-2.872-.552C15.432.016 15.032 0 11.824 0S8.208 0 6.952.072C5.97.092 5 .28 4.08.624 2.493 1.238 1.238 2.494.624 4.08.28 5 .092 5.97.072 6.952.016 8.216 0 8.616 0 11.824s0 3.616.072 4.872c.02.982.207 1.953.552 2.872.614 1.587 1.87 2.842 3.456 3.456.917.36 1.888.56 2.872.592 1.264.056 1.664.072 4.872.072s3.616 0 4.872-.072c.982-.02 1.953-.207 2.872-.552 1.587-.614 2.842-1.87 3.456-3.456.345-.92.532-1.89.552-2.872.056-1.264.072-1.664.072-4.872s0-3.616-.072-4.872c-.016-.995-.202-1.98-.552-2.912zm-1.6 12.52c-.007.757-.145 1.506-.408 2.216-.398 1.033-1.215 1.85-2.248 2.248-.702.26-1.443.398-2.192.408-1.248.056-1.6.072-4.8.072-3.2 0-3.528 0-4.8-.072-.75-.01-1.49-.148-2.192-.408-1.037-.395-1.857-1.213-2.256-2.248-.26-.702-.398-1.443-.408-2.192-.056-1.248-.072-1.6-.072-4.8 0-3.2 0-3.528.072-4.8.007-.757.145-1.506.408-2.216.4-1.035 1.22-1.853 2.256-2.248.702-.26 1.443-.398 2.192-.408 1.248-.056 1.6-.072 4.8-.072 3.2 0 3.528 0 4.8.072.75.01 1.49.148 2.192.408 1.033.398 1.85 1.215 2.248 2.248.26.702.398 1.443.408 2.192.056 1.248.072 1.6.072 4.8 0 3.2 0 3.544-.056 4.8h-.016z"></path></g></svg></a></li></ul><ul class="links"><li><a href="/pages/about">About</a></li><li><a href="/pages/advertise">Advertise</a></li><li><a href="/pages/contact">Contact Us</a></li><li><a href="https://careers.bleacherreport.com/">Careers</a></li><li><a href="/pages/comguidelines">Community Guidelines</a></li><li><a href="/pages/privacy">Privacy</a></li><li><a href="#">Do Not Sell My Personal Information</a></li><li><a href="/pages/terms">Terms Of Use</a></li><li><a href="https://www.stubhub.com/?gcid=chAFF-_-geoUS-_-genAllTix-_-dt170312-_-cmpBR_footr-_-partBleacherReport">Tickets</a></li><li><a href="#">AdChoices <img src="https://static-assets.bleacherreport.net/img/molecules/footer/adChoices.png" width="12" height="12" alt="" role="presentation" style="vertical-align:middle"/></a></li></ul></div><small class="copyright">
  Copyright © 2020 Bleacher Report, Inc. Turner Broadcasting System, Inc.
  All Rights Reserved.
  BleacherReport.com is part of Bleacher Report – Turner Sports Network, part of the Turner Sports and Entertainment Network.
<!-- -->
  Certain photos copyright © 2020 Getty Images.
  Any commercial use or distribution without the express written consent of Getty Images is strictly prohibited.
<a href="#">AdChoices <img src="https://static-assets.bleacherreport.net/img/molecules/footer/adChoices.png" width="12" height="12" alt="" role="presentation" style="vertical-align:middle"/></a></small><svg class="atom logo svg turner" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 601.7 105.2"><title>Turner Logo</title><path d="M502.3 63.5c1.7-7.2 2.7-13.3 2.7-19.3C505 19.6 488.5.1 460.5.1 430 .1 405.7 22.9 401 52.6c-5 31.5 14.3 52.5 44.2 52.5 23.6 0 43.5-13.3 53.7-33.5h-36.1c-4.5 4.7-10.5 6-15.7 5.9-10.4-.2-15.3-6.3-15.4-14h70.6zm-43.7-36.9c9.2 0 15.4 5.8 15.1 14.5h-37c3.5-8.5 11.8-14.5 21.9-14.5zM579 .6c-12.5 0-22.8 10.2-22.8 22.6 0 12.6 10.3 22.9 22.8 22.9 12.6 0 22.9-10.3 22.7-22.9C601.9 10.7 591.6.6 579 .6zM364.9 0c-11.4 0-25.3 6.9-32 16l3.8-13.4h-32.4l-17.7 100.2h34.8l10-56.7c1.7-9.4 9-15.9 17.7-15.9 8.4 0 12.4 6.9 10.9 15.9l-10 56.7h34.8l10.9-61.5C400.1 16 387.8 0 364.9 0zM5.7 2.6h91.6l-5.7 32.2H63.8l-12 67.9H17l12-67.9H0M105.3 2.6h34.8l-9.8 55.7c-1.7 9.6 2.7 15.3 11.2 15.3 8.7 0 15.5-6 17.2-15.3l9.8-55.7h34.8L193.9 56c-6 33.4-27.7 49-56.9 49-29.8 0-46.9-16.3-41.1-49.2l9.4-53.2zM194.6 102.7h34.7L247 2.6h-34.8M270.2.6c-12.4 0-22.8 10.2-22.8 22.6 0 12.6 10.3 22.9 22.8 22.9 12.6 0 22.9-10.3 22.8-22.9.1-12.5-10.2-22.6-22.8-22.6zM503.3 102.7H538L555.7 2.6h-34.8"></path></svg></footer></div></div></div><script id="__LOADABLE_REQUIRED_CHUNKS__" type="application/json">[]</script><script async="" data-chunk="bundle" src="https://static-assets.bleacherreport.net/js/vendor-d20fce23.js"></script><script async="" data-chunk="bundle" src="https://static-assets.bleacherreport.net/js/bundle.5effe5287db922dfdf2da959d31268a5.js"></script><div id="pixels"></div><div id="infogram-async"></div><div><!-- Generated on 12/08/20 at 12:48 AM --></div></body></html>