<!DOCTYPE html><html class="no-js" lang="en" data-reactroot=""><head><meta charSet="utf-8"/><meta http-equiv="Accept-CH" content="DPR,Width,Viewport-Width"/><meta name="aol-te-auth" content="1c424580-0f86-4d9b-88b2-bc8c0d029d4c"/><meta name="blitz" content="mu-6e4ce5cd-57f20d11-7c0ecee9-d55c79e2"/><meta name="msvalidate.01" content="7A63840181953B2A5A1FEA25FB45A991"/><meta name="robots" content="NOODP,NOYDIR"/><meta name="verify-v1" content="+Ntj422Jc4V03qgBqLYbF3LMvrursV0X2btn2Zoqn9w="/><meta name="description" content="We&#x27;re at an interesting point in the 2022  NFL  offseason when a second flurry of free-agent signings could transpire. Teams have needs that weren&#x27;t filled during the draft, and several quality free agents remain unsigned..."/><meta name="viewport" content="width=device-width, initial-scale=1"/><meta property="fb:app_id" content="135174055162"/><meta name="al:iphone:url" content="teamstream://article/bleacherreport.com/articles/2955993-surprise-nfl-free-agents-who-could-go-unsigned-heading-into-training-camps"/><meta name="al:iphone:app_store_id" content="418075935"/><meta name="al:iphone:app_name" content="Bleacher Report"/><meta name="al:ipad:url" content="teamstream://article/bleacherreport.com/articles/2955993-surprise-nfl-free-agents-who-could-go-unsigned-heading-into-training-camps"/><meta name="al:ipad:app_store_id" content="484725748"/><meta name="al:ipad:app_name" content="Bleacher Report"/><meta name="al:android:url" content="https://bleacherreport.com/articles/2955993-surprise-nfl-free-agents-who-could-go-unsigned-heading-into-training-camps"/><meta name="al:android:app_name" content="Bleacher Report"/><meta name="al:android:package" content="com.bleacherreport.android.teamstream"/><meta name="al:web:url" content="https://bleacherreport.com/articles/2955993-surprise-nfl-free-agents-who-could-go-unsigned-heading-into-training-camps"/><meta property="og:site_name" content="Bleacher Report"/><meta property="og:locale" content="en_US"/><meta name="p:domain_verify" content="0c768466449ebb550411234d6d4ffc30"/><meta name="theme-color" content="#000"/><meta name="twitter:app:name:iphone" content="Bleacher Report"/><meta name="twitter:app:id:iphone" content="418075935"/><meta name="twitter:app:name:ipad" content="Bleacher Report"/><meta name="twitter:app:id:ipad" content="484725748"/><meta name="twitter:app:name:googleplay" content="Bleacher Report"/><meta name="twitter:app:id:googleplay" content="com.bleacherreport.android.teamstream"/><meta name="twitter:widgets:new-embed-design" content="on"/><meta name="twitter:site" content="@bleacherreport"/><meta name="article:publisher" content="https://www.facebook.com/bleacherreport"/><meta name="author" content="Kristopher Knox"/><meta property="og:description" content="We&#x27;re at an interesting point in the 2022  NFL  offseason when a second flurry of free-agent signings could transpire. Teams have needs that weren&#x27;t filled during the draft, and several quality free agents remain unsigned..."/><meta property="og:image" content="https://img.bleacherreport.net/img/images/photos/003/921/665/hi-res-7b3d15247c989ab776fc2af757f462f6_crop_exact.jpg?w=1200&amp;h=1200&amp;q=75"/><meta property="og:title" content="Surprise NFL Free Agents Who Could Go Unsigned Heading into Training Camps"/><meta property="og:type" content="article"/><meta property="og:url" content="https://bleacherreport.com/articles/2955993-surprise-nfl-free-agents-who-could-go-unsigned-heading-into-training-camps"/><meta name="pubdate" content="2022-05-07T09:16:16-04:00"/><meta name="thumbnail" content="https://img.bleacherreport.net/img/images/photos/003/921/665/hi-res-7b3d15247c989ab776fc2af757f462f6_crop_exact.jpg?w=1200&amp;h=1200&amp;q=75"/><meta name="twitter:app:url:googleplay" content="https://bleacherreport.com/articles/2955993-surprise-nfl-free-agents-who-could-go-unsigned-heading-into-training-camps"/><meta name="twitter:app:url:ipad" content="teamstream://article/bleacherreport.com/articles/2955993-surprise-nfl-free-agents-who-could-go-unsigned-heading-into-training-camps"/><meta name="twitter:app:url:iphone" content="teamstream://article/bleacherreport.com/articles/2955993-surprise-nfl-free-agents-who-could-go-unsigned-heading-into-training-camps"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:description" content="We&#x27;re at an interesting point in the 2022  NFL  offseason when a second flurry of free-agent signings could transpire. Teams have needs that weren&#x27;t filled during the draft, and several quality free agents remain unsigned..."/><meta name="twitter:image" content="https://img.bleacherreport.net/img/images/photos/003/921/665/hi-res-7b3d15247c989ab776fc2af757f462f6_crop_exact.jpg?w=1200&amp;h=1200&amp;q=75"/><meta name="twitter:title" content="Surprise NFL Free Agents Who Could Go Unsigned Heading into Training Camps"/><meta name="twitter:url" content="https://bleacherreport.com/articles/2955993-surprise-nfl-free-agents-who-could-go-unsigned-heading-into-training-camps"/><link rel="shortcut icon" href="https://static-assets.bleacherreport.net/favicon.ico"/><title>Surprise NFL Free Agents Who Could Go Unsigned Heading into Training Camps | Bleacher Report | Latest News, Videos and Highlights</title><script src="//d1je72vo6cxqo9.cloudfront.net/script.js" async="" id="rwxsawuta"></script><script type="text/javascript">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</script><script src="//d1je72vo6cxqo9.cloudfront.net/script.js" async="" id="rwxsawuta"></script><script type="application/ld+json">{"@context":"http://schema.org","@type":"NewsArticle","about":"We're at an interesting point in the 2022  NFL  offseason when a second flurry of free-agent signings could transpire. Teams have needs that weren't filled during the draft, and several quality free agents remain unsigned...","author":{"@type":"Person","name":"Kristopher Knox","jobTitle":"Featured Columnist"},"dateModified":"2022-05-07T09:16:40-04:00","datePublished":"2022-05-07T09:16:16-04:00","description":"We're at an interesting point in the 2022  NFL  offseason when a second flurry of free-agent signings could transpire. Teams have needs that weren't filled during the draft, and several quality free agents remain unsigned...","headline":"Surprise NFL Free Agents Who Could Go Unsigned Heading into Training Camps","image":{"type":"ImageObject","url":"https://img.bleacherreport.net/img/images/photos/003/921/665/hi-res-7b3d15247c989ab776fc2af757f462f6_crop_exact.jpg?w=900&h=600&q=75"},"inLanguage":"English","isFamilyFriendly":true,"keywords":"NFL,Julio_Jones,Rankings_List,Jared_Cook,Nick_Foles,SBS","mainEntityOfPage":"We're at an interesting point in the 2022  NFL  offseason when a second flurry of free-agent signings could transpire. Teams have needs that weren't filled during the draft, and several quality free agents remain unsigned...","publisher":{"@type":"Organization","name":"Bleacher Report","url":"https://bleacherreport.com","logo":{"type":"ImageObject","url":"https://static-assets.bleacherreport.net/img/br_60_height.png","width":"80","height":"60"}},"thumbnailURL":"https://img.bleacherreport.net/img/images/photos/003/921/665/hi-res-7b3d15247c989ab776fc2af757f462f6_crop_exact.jpg?w=900&h=600&q=75"}</script><script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://bleacherreport.com","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https://bleacherreport.com/nfl","name":"NFL"}}]}</script><link rel="manifest" type="" href="/manifest.json" crossorigin="anonymous" class="" media="all"/><link rel="mask-icon" type="" href="/img/favicon/safariMaskIcon.svg" color="#000000" crossorigin="anonymous" class="" media="all"/><link rel="apple-touch-icon" type="" href="/img/favicon/appleTouchIcon.png" sizes="180x180" crossorigin="anonymous" class="" media="all"/><link rel="icon" type="" href="/img/favicon/favicon32.png" sizes="32x32" crossorigin="anonymous" class="" media="all"/><link rel="icon" type="" href="/img/favicon/favicon16.png" sizes="16x16" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://ib.adnxs.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://prebid.adnxs.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://secure.adnxs.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://fastlane.rubiconproject.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://optimized-by.rubiconproject.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://ads.rubiconproject.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://fastlane-adv.rubiconproject.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://aax.amazon-adsystem.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://c.amazon-adsystem.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://bidder.criteo.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://static.criteo.net" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://js-sec.indexww.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://as-sec.casalemedia.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://observe.aniview.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://mcdp-chidc2.outbrain.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://log.outbrainimg.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://videoclientsservicescalls.outbrain.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://e.infogr.am" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://serv.vid-play.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://servt.vid-play.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://track.aniview.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://pistyll.bleacherreport.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://geo.moatads.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://preferences.truste.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://vis.vi-serve.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://t.vi-serve.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://s.vi-serve.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://secure-us.imrworldwide.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://www.facebook.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://connect.facebook.net" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://pixel.adsafeprotected.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://www.instagram.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://platform.instagram.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://tags.tiqcdn.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://d1je72vo6cxqo9.cloudfront.net" crossorigin="anonymous" class="" media="all"/><link rel="preconnect" type="" href="https://d1je72vo6cxqo9.cloudfront.net" crossorigin="anonymous" class="" media="all"/><link rel="preconnect" type="" href="https://static-assets.bleacherreport.net" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://static-assets.bleacherreport.net" crossorigin="anonymous" class="" media="all"/><link rel="preconnect" type="" href="https://cdn.bleacherreport.net" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://cdn.bleacherreport.net" crossorigin="anonymous" class="" media="all"/><link rel="preconnect" type="" href="https://cdn.bitmovin.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://cdn.bitmovin.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://www.ugdturner.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://cdn.krxd.net" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://i.cdn.turner.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://jssdkcdns.mparticle.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://platform.twitter.com" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/proxima-nova/proxima-nova-regular.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/proxima-nova/proxima-nova-regular-italic.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/proxima-nova/proxima-nova-medium.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/proxima-nova/proxima-nova-bold.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/effra/effra-regular.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/effra/effra-medium.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/effra/effra-bold.woff2" crossorigin="anonymous" class="" media="all"/><link rel="amphtml" type="" href="https://syndication.bleacherreport.com/amp/2955993-surprise-nfl-free-agents-who-could-go-unsigned-heading-into-training-camps.amp.html" crossorigin="anonymous" class="" media="all"/><link rel="alternate" type="" href="android-app://com.bleacherreport.android.teamstream/http/bleacherreport.com/articles/2955993-surprise-nfl-free-agents-who-could-go-unsigned-heading-into-training-camps" crossorigin="anonymous" class="" media="all"/><link rel="alternate" type="" href="android-app://com.bleacherreport.android.teamstream/teamstream/article/bleacherreport.com/articles/2955993-surprise-nfl-free-agents-who-could-go-unsigned-heading-into-training-camps" crossorigin="anonymous" class="" media="all"/><link rel="alternate" type="" href="ios-app://418075935/http/bleacherreport.com/articles/2955993-surprise-nfl-free-agents-who-could-go-unsigned-heading-into-training-camps" crossorigin="anonymous" class="" media="all"/><link rel="canonical" type="" href="https://bleacherreport.com/articles/2955993-surprise-nfl-free-agents-who-could-go-unsigned-heading-into-training-camps" crossorigin="anonymous" class="" media="all"/><link rel="alternate" type="application/json+oembed" href="https://embeder.bleacherreport.com/oembed?url=https%3A%2F%2Fbleacherreport.com%2Farticles%2F2955993-surprise-nfl-free-agents-who-could-go-unsigned-heading-into-training-camps" crossorigin="anonymous" class="" media="all"/><style id="critical-css" data-used-styles="true">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</style><link rel="preload" as="style" href="https://static-assets.bleacherreport.net/css/atomic.65500f3dd4af32f48d11.css"/><link rel="preload" as="style" href="https://static-assets.bleacherreport.net/css/atomic.shell.css"/><link rel="preload" as="style" href="https://static-assets.bleacherreport.net/css/global.8aefdeea8655b03ee786.css"/><link rel="preload" as="style" href="https://static-assets.bleacherreport.net/css/global.shell.css"/></head><body><div id="app"><div class="template website light"><div class="fixedRegion"><div class="fixedBottom"></div></div><header><div class="nav organism"><a id="br-logo" class="siteLogo" href="/"><svg class="atom logo svg br" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 1600 1200"><title>Bleacher Report Logo</title><g><path d="M484.85 200H200v800h284.85L600 884.85v-229.7L544.85 600 600 544.85v-229.7zM320 540V320h115.15L480 364.85v130.3L435.15 540zm115.15 120L480 704.85v130.3L435.15 880H320V660zM1415 1000l-99.35-370.79 84.35-84.36v-229.7L1284.85 200H1000v800h120V660h83.9l91.1 340zm-295-680h115.15l44.85 44.85v130.3L1235.15 540H1120zM700 770.71l200-200V429.29l-200 200v141.42z"></path></g></svg></a><nav id="league-links"><ol class="molecule nav-list"><li class="atom nav-link parent-link top-level" id="nba"><a href="/nba">NBA</a></li><li class="atom nav-link parent-link top-level" id="nfl"><a href="/nfl">NFL</a></li><li class="atom nav-link parent-link top-level" id="mlb"><a href="/mlb">MLB</a></li><li class="atom nav-link parent-link top-level" id="nhl"><a href="/nhl">NHL</a></li><li class="atom nav-link top-level" id="videos"><a href="/videos">Videos</a></li><li class="atom nav-link parent-link top-level" id="world-football"><a href="/world-football">World Football</a></li><li class="atom nav-link parent-link top-level" id="college-basketball"><a href="/college-basketball">MCBB</a></li><li class="atom nav-link top-level" id="womens-college-basketball"><a href="/womens-college-basketball">WCBB</a></li><li class="atom nav-link parent-link top-level" id="college-football"><a href="/college-football">CFB</a></li><li class="atom nav-link top-level" id="all-elite-wrestling"><a href="/all-elite-wrestling">AEW</a></li><li class="atom nav-link top-level" id="all-elite-wrestling-ppv"><a href="/videos/all-elite-wrestling-ppv">AEW PPV</a></li><li class="atom nav-link top-level" id="wwe"><a href="/wwe">WWE</a></li><li class="atom nav-link top-level" id="mma"><a href="/mma">MMA</a></li><li class="atom nav-link top-level" id="wnba"><a href="/wnba">WNBA</a></li><li class="atom nav-link top-level" id="formula-1"><a href="/formula-1">F1</a></li><li class="atom nav-link top-level" id="golf"><a href="/golf">Golf</a></li><li class="atom nav-link top-level" id="tennis"><a href="/tennis">Tennis</a></li><li class="atom nav-link top-level" id="boxing"><a href="/boxing">Boxing</a></li><li class="atom nav-link parent-link top-level" id="more"><span>More</span></li></ol></nav><nav id="non-league-links"><ol class="molecule nav-list"><li class="atom nav-link parent-link top-level" id="shows"><span>Shows</span></li><li class="atom nav-link top-level" id="kicks"><a href="/kicks">B/R Kicks</a></li><li class="atom nav-link top-level" id="gaming"><a href="/gaming">B/R Gaming</a></li><li class="atom nav-link top-level" id="gridiron"><a href="https://www.instagram.com/brgridiron/">B/R Gridiron</a></li><li class="atom nav-link top-level" id="mobile"><a href="/mobile">Get the App</a></li><li class="atom nav-link top-level" id="https://bleacherreportshop.com/?utm_source=Bleacher%20Report&amp;utm_medium=referral&amp;utm_campaign=Bleacher%20Report%20Website%20Menu"><a href="https://bleacherreportshop.com/?utm_source=Bleacher%20Report&amp;utm_medium=referral&amp;utm_campaign=Bleacher%20Report%20Website%20Menu">B/R Shop</a></li></ol></nav><div class="tools-container"><ul class="userTools molecule"><li class="molecule userMenu"><img src="https://static-assets.bleacherreport.net/img/molecules/nav/flagUSGray.png" alt="content has been localized for visitors from the United States" class="flag"/>Account<div class="dropdown"><ul><li><a href="/sign_up" class="sign-up">Sign Up</a></li><li><a href="/sign_in" class="login">Login</a></li><li><a href="https://support.bleacherreport.com/" class="getHelp">Get Help</a></li></ul><div class="dropdown-header">Edition</div><div class="atom dropdown-body"><ul class="edition-flags"><li><a class="selected" href="/us"><img src="https://static-assets.bleacherreport.net/img/molecules/nav/flagUS.png" alt="United States of America flag"/></a></li><li><a class="" href="/uk"><img src="https://static-assets.bleacherreport.net/img/molecules/nav/flagUK.png" alt="Great Britain flag"/></a></li></ul></div></div></li></ul></div></div></header><div class="atom score-card-carousel"><div class="react-multi-carousel-list  "><ul class="react-multi-carousel-track slider" style="transition:none;overflow:unset;transform:translate3d(0px,0,0)"></ul></div></div><div id="outer-container" class=""><div class="ad"><div class="br-ad-wrapper atom advert"><div id="br-ad-5" class="br-ad" data-collapsed="0" data-country="US" data-position="oop_skin_01" data-reload="1" data-responsive-size="[[[970,0],[[3,3]]],[[0,0],[]]]" data-size="[[3,3]]"></div></div></div><div class="ad"><div class="br-ad-wrapper atom advert"><div id="br-ad-1" class="br-ad" data-collapsed="0" data-country="US" data-position="bnr_atf_01" data-reload="2" data-responsive-size="[[[1280,0],[&quot;fluid&quot;,[1280,100],[970,250],[970,66],[728,90]]],[[970,0],[&quot;fluid&quot;,[970,250],[970,66],[728,90]]],[[728,0],[&quot;fluid&quot;,[728,90],[300,100],[320,50]]],[[0,0],[&quot;fluid&quot;,[300,100],[320,50]]]]" data-size="[[320,50],[320,1]]"></div></div></div><div id="main-content"><div id="ad-skin-measurability-l" class="ad-rail"></div><div id="page-content"><article class="page articlePage"><header><div class="atom share"><ul><li class="shareFacebook" title="Share this article on Facebook"><svg class="atom icon svg facebook" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 10 16"><title>Facebook Logo</title><path d="M6.24 16V8.7h2.45l.365-2.842H6.24V4.04c0-.822.227-1.384 1.41-1.384h1.5V.112C8.42.035 7.686-.002 6.953 0 4.79 0 3.3 1.325 3.3 3.76v2.098H.846V8.7H3.3V16h2.94z"></path></svg></li><li class="shareTwitter" title="Share this article on Twitter"><svg class="atom icon svg twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 14"><title>Twitter Logo</title><path d="M5.042 13.504c6.01 0 9.3-4.985 9.3-9.3 0-.14 0-.28-.006-.42.638-.46 1.192-1.04 1.632-1.697-.586.262-1.217.434-1.88.517.675-.402 1.192-1.046 1.44-1.81-.63.375-1.332.643-2.078.79C12.85.946 12.003.55 11.066.55c-1.804 0-3.27 1.467-3.27 3.27 0 .256.032.505.083.747-2.717-.134-5.126-1.44-6.74-3.417C.86 1.635.7 2.196.7 2.795c0 1.134.58 2.135 1.455 2.722-.536-.02-1.04-.166-1.48-.408v.043c0 1.58 1.13 2.907 2.62 3.207-.273.076-.56.115-.86.115-.21 0-.414-.02-.612-.058.414 1.3 1.626 2.244 3.053 2.27-1.12.88-2.53 1.402-4.06 1.402-.26 0-.523-.014-.778-.046 1.44.918 3.162 1.46 5.004 1.46"></path></svg></li><li class="shareLink" title="Copy this link to your clipboard"><svg class="atom icon svg link" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20 10"><title>Copy Link Icon</title><path d="M1.9 5c0-1.71 1.39-3.1 3.1-3.1h4V0H5C2.24 0 0 2.24 0 5s2.24 5 5 5h4V8.1H5C3.29 8.1 1.9 6.71 1.9 5zM6 6h8V4H6v2zm9-6h-4v1.9h4c1.71 0 3.1 1.39 3.1 3.1 0 1.71-1.39 3.1-3.1 3.1h-4V10h4c2.76 0 5-2.24 5-5s-2.24-5-5-5z"></path></svg></li></ul></div><button class="atom button" type="button"><nav class="organism nr-breadcrumb"><ol itemscope="" itemType="https://schema.org/BreadcrumbList" class="nr-breadcrumb__list"><li itemProp="itemListElement" itemscope="" itemType="https://schema.org/ListItem" class="nr-breadcrumb__element"><a itemProp="item" itemType="https://schema.org/WebPage" href="https://bleacherreport.com" class="nr-breadcrumb__link"><span itemProp="name" class="nr-breadcrumb__name">Home</span></a><meta itemProp="position" content="1"/></li><span class="nr-breadcrumb__divider">&gt;</span><li itemProp="itemListElement" itemscope="" itemType="https://schema.org/ListItem" class="nr-breadcrumb__element"><a itemProp="item" itemType="https://schema.org/WebPage" href="https://bleacherreport.com/nfl" class="nr-breadcrumb__link"><span itemProp="name" class="nr-breadcrumb__name">NFL</span></a><meta itemProp="position" content="2"/></li></ol></nav></button><h1>Surprise NFL Free Agents Who Could Go Unsigned Heading into Training Camps</h1><span class="atom authorInfo"><a href="/users/6e186227-f9b2-4450-af0d-8f62243323ee" rel="noopener noreferrer"><span class="name">Kristopher Knox</span></a><a class="twitterHandle" rel="noopener noreferrer" target="_blank" href="http://twitter.com/@kris_knox"><span>@<!-- -->@kris_knox</span><svg class="atom icon svg twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 14"><title>Twitter Logo</title><path d="M5.042 13.504c6.01 0 9.3-4.985 9.3-9.3 0-.14 0-.28-.006-.42.638-.46 1.192-1.04 1.632-1.697-.586.262-1.217.434-1.88.517.675-.402 1.192-1.046 1.44-1.81-.63.375-1.332.643-2.078.79C12.85.946 12.003.55 11.066.55c-1.804 0-3.27 1.467-3.27 3.27 0 .256.032.505.083.747-2.717-.134-5.126-1.44-6.74-3.417C.86 1.635.7 2.196.7 2.795c0 1.134.58 2.135 1.455 2.722-.536-.02-1.04-.166-1.48-.408v.043c0 1.58 1.13 2.907 2.62 3.207-.273.076-.56.115-.86.115-.21 0-.414-.02-.612-.058.414 1.3 1.626 2.244 3.053 2.27-1.12.88-2.53 1.402-4.06 1.402-.26 0-.523-.014-.778-.046 1.44.918 3.162 1.46 5.004 1.46"></path></svg></a><span class="title">Featured Columnist</span></span><span class="date">May 7, 2022</span><button class="atom button commentCount" type="button"><span class="label"> <!-- -->Comments</span><svg class="atom icon svg commentBubble" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20 20"><title>Comment Bubble Icon</title><path d="M2 0h16c1.1 0 2 .9 2 2v18l-4-4H2c-1.1 0-2-.9-2-2V2C0 .9.9 0 2 0z"></path></svg></button></header><div class="organism contentStream slideshow"><div><div class="organism contentStream slide" id="slide0"><h1>Surprise NFL Free Agents Who Could Go Unsigned Heading into Training Camps</h1><div class="slideData">0 of 8</div><ol><div class="atom photo" itemscope="" itemType="http://schema.org/ImageObject"><p></p><div class="imgWrapper"><div class="atom articleLeadImage blurUp"><img alt="" src="https://media.bleacherreport.com/w_40,h_27,c_fill/br-img-slides/004/517/592/7b3d15247c989ab776fc2af757f462f6_crop_exact.jpg" itemProp="contentUrl"/></div></div><small><span class="caption"></span><span itemProp="citation" class="credit">Dylan Buell/Getty Images</span></small></div><p class="">We&apos;re at an interesting point in the 2022 <a href="http://bleacherreport.com/nfl">NFL</a> offseason when a second flurry of free-agent signings could transpire. Teams have needs that weren&apos;t filled during the draft, and several quality free agents remain unsigned.</p><p class="">Plus, players signed now—after 4 p.m. ET on the Monday after the draft—won&apos;t count against next year&apos;s compensatory formula. It&apos;s a big reason the market slowed before the draft and could pick up again.</p><p class="">The New Orleans Saints, for example, waited until Wednesday to sign star safety Tyrann Mathieu and won&apos;t risk missing out on a potential compensatory pick for a departed player like Terron Armstead or Marcus Williams.</p><p class="">However, while we&apos;re likely to see the market pick back up, several notable veterans could remain on the market all the way into training camp. The following eight players can be key contributors in 2022 but could remain available when camps open thanks to factors like age, health, projected role, positional value and other player-specific reasons.</p><p class="">We&apos;ll dive into both the upside these players can provide and the reasons they could still be available in August. Players are listed in alphabetical order.</p></ol></div><div class="organism contentStream slide" id="slide1"><div class="ad"><div class="lazy br-ad-wrapper atom advert"><div id="br-ad-2955993-1" class="br-ad-lazy" data-collapsed="0" data-country="US" data-position="rect_atf_01" data-reload="1" data-responsive-size="[[[970,0],[&quot;fluid&quot;,[970,250],[970,66],[728,90],[300,250]]],[[728,0],[&quot;fluid&quot;,[728,90],[300,250]]],[[0,0],[&quot;fluid&quot;,[300,250],[320,50]]]]" data-size="[[300,600],[300,250],[300,2]]"></div></div></div><h1>K Michael Badgley</h1><div class="slideData">1 of 8</div><ol><div class="atom photo" itemscope="" itemType="http://schema.org/ImageObject"><p></p><div class="imgWrapper"><div class="atom articleLeadImage blurUp"><img alt="" src="https://media.bleacherreport.com/w_40,h_27,c_fill/br-img-slides/004/517/600/a1f42c0cac3b306995da9ac2036e2f57_crop_exact.jpg" itemProp="contentUrl"/></div></div><small><span class="caption"></span><span itemProp="citation" class="credit">Eric Christian Smith/Associated Press</span></small></div><p class="">Kicker Michael Badgley lasted just one game last season with the Tennessee Titans, who released him after he missed a field goal and an extra point in Week 1. However, he landed with the Indianapolis Colts in October and had a solid, if unspectacular, season.</p><p class="">In 12 games with Indy, Badgley made 85.7 percent of his field-goal attempts and all 39 of his point-after tries. While he didn&apos;t convert a field goal longer than 50 yards, he was reliable enough to make his way onto a roster in 2022.</p><p class="">However, Badgley might remain unemployed until just before the season. Teams are likely to let their kicking competitions play out while viewing Badgley as a veteran fallback option. The 26-year-old can be serviceable, but teams will prefer a younger and cheaper option with a bigger leg—Badgley is 3-of-10 on attempts longer than 50 yards in his career—if they can get it.</p><p class="">Badgley didn&apos;t sign with the Titans until September last year, and he could face a similar timeline in 2022. Expect him to fill a role that isn&apos;t solidified during camp and the preseason.</p></ol></div><div class="organism contentStream slide" id="slide2"><div class="ad"><div class="lazy br-ad-wrapper atom advert"><div id="br-ad-2955993-2" class="br-ad-lazy" data-collapsed="0" data-country="US" data-position="rect_atf_02" data-reload="1" data-responsive-size="[[[970,0],[&quot;fluid&quot;,[970,250],[970,66],[728,90],[300,250]]],[[728,0],[&quot;fluid&quot;,[728,90],[300,250]]],[[0,0],[&quot;fluid&quot;,[300,250],[320,50]]]]" data-size="[[300,600],[300,250],[300,2]]"></div></div></div><h1>OT Bryan Bulaga</h1><div class="slideData">2 of 8</div><ol><div class="atom photo" itemscope="" itemType="http://schema.org/ImageObject"><p></p><div class="imgWrapper"><div class="atom articleLeadImage blurUp"><img alt="" src="https://media.bleacherreport.com/w_40,h_27,c_fill/br-img-slides/004/517/597/9204b7bd07833072722711840ab142da_crop_exact.jpg" itemProp="contentUrl"/></div></div><small><span class="caption"></span><span itemProp="citation" class="credit">Alex Gallardo/Associated Press</span></small></div><p class="">Like Badgley, offensive tackle Bryan Bulaga is likely to join a roster as a late-offseason insurance option. The former Green Bay Packers and Los Angeles Chargers vet has been a reliable starter at right tackle but has struggled to stay on the field recently.</p><p class="">Bulaga started 30 games for the Packers in 2018 and 2019. However, his 2017 campaign was cut short by a torn ACL, and the 33-year-old only appeared in 11 games over the past two seasons. A back injury cost Bulaga six games in 2020, while back and groin injuries limited him to a single start in 2021.</p><p class="">Because of his injury history, teams may not want to risk overworking Bulaga in OTAs and early training camp. He has 122 career starts and shouldn&apos;t<em> </em>need much time to get up to speed by Week 1.</p><p class="">Bulaga played well in his first season with the Chargers in 2020, logging no penalties and two sacks allowed in 10 appearances, according to <a href="https://www.pff.com/nfl/players/bryan-bulaga/5548?season=2020" target="_blank" rel="noopener noreferrer">Pro Football Focus</a>.</p><p class="">Because of his injury history and age, he also probably has little interest in joining a program early. A late-camp signing would be a win-win for both Bulaga and his next team, which might not put pen to paper until after evaluating its tackle needs in the preseason.</p></ol></div><div class="organism contentStream slide" id="slide3"><div class="ad"><div class="lazy br-ad-wrapper atom advert"><div id="br-ad-2955993-3" class="br-ad-lazy" data-collapsed="0" data-country="US" data-position="rect_atf_03" data-reload="1" data-responsive-size="[[[970,0],[&quot;fluid&quot;,[970,250],[970,66],[728,90],[300,250]]],[[728,0],[&quot;fluid&quot;,[728,90],[300,250]]],[[0,0],[&quot;fluid&quot;,[300,250],[320,50]]]]" data-size="[[300,600],[300,250],[300,2]]"></div></div></div><h1>TE Jared Cook</h1><div class="slideData">3 of 8</div><ol><div class="atom photo" itemscope="" itemType="http://schema.org/ImageObject"><p></p><div class="imgWrapper"><div class="atom articleLeadImage blurUp"><img alt="" src="https://media.bleacherreport.com/w_40,h_27,c_fill/br-img-slides/004/517/599/2f55956001d9f7bcc1a6942ef62c2d91_crop_exact.jpg" itemProp="contentUrl"/></div></div><small><span class="caption"></span><span itemProp="citation" class="credit">Carmen Mandato/Getty Images</span></small></div><p class="">Tight end Jared Cook is another aging veteran who probably doesn&apos;t want to battle in the summer heat any more than he has to. The two-time Pro Bowler is 35 years old and has a long history of stepping into new situations and being productive.</p><p class="">Cook, a 2009 third-round pick of the Titans, has played for six different franchises. He topped the 500-yard mark in at least one season for five of them. Last season with the Chargers, Cook caught 48 passes for 564 yards and four touchdowns.</p><p class="">The South Carolina product can be a reliable low-end starter—he&apos;s missed only four games in the past five years—but he isn&apos;t likely to be a team&apos;s first choice. Cook is likely a one- or two-year option at best, and teams will opt for youth and upside if they can get it.</p><p class="">However, Cook has shown time and time again that he can step into a new offense and be a key cog in the passing attack. He&apos;s the best pass-catching tight end left on the market, and if a team isn&apos;t happy with its internal options by the start of the preseason, it will give Cook a call.</p></ol></div><div class="organism contentStream slide" id="slide4"><div class="ad"><div class="lazy br-ad-wrapper atom advert"><div id="br-ad-2955993-4" class="br-ad-lazy" data-collapsed="0" data-country="US" data-position="rect_atf_03" data-reload="1" data-responsive-size="[[[970,0],[&quot;fluid&quot;,[970,250],[970,66],[728,90],[300,250]]],[[728,0],[&quot;fluid&quot;,[728,90],[300,250]]],[[0,0],[&quot;fluid&quot;,[300,250],[320,50]]]]" data-size="[[300,600],[300,250],[300,2]]"></div></div></div><h1>QB Nick Foles</h1><div class="slideData">4 of 8</div><ol><div class="atom photo" itemscope="" itemType="http://schema.org/ImageObject"><p></p><div class="imgWrapper"><div class="atom articleLeadImage blurUp"><img alt="" src="https://media.bleacherreport.com/w_40,h_27,c_fill/br-img-slides/004/517/593/acc2327bb666fc4e1a4f2c718aa0a660_crop_exact.jpg" itemProp="contentUrl"/></div></div><small><span class="caption"></span><span itemProp="citation" class="credit">Stephen Maturen/Getty Images</span></small></div><p class="">The Chicago Bears released quarterback <a href="http://bleacherreport.com/nick-foles">Nick Foles</a> last week, which leaves a former Super Bowl MVP on the open market. The 33-year-old is an enticing depth or bridge option, though he may have to wait until the preseason to get his next opportunity.</p><p class="">Teams know what Foles is at this point in his career. He helped the Philadelphia Eagles win a Super Bowl in 2017 and was a Pro Bowler in 2013, but the 10-year veteran is nothing more than a spot starter or high-end backup.</p><p class="">Foles&apos; last significant opportunity came in 2020 when he made seven starts for the Bears but didn&apos;t play well enough to keep Mitchell Trubisky on the bench. Teams that need a starter won&apos;t rush to sign Foles, especially since Baker Mayfield and Jimmy Garoppolo are looming as potential cut casualties.</p><p class="">Teams in need of a backup quarterback probably won&apos;t hurry to sign Foles either. Veteran journeymen of his ilk aren&apos;t bargain-basement cheap—<a href="http://bleacherreport.com/andy-dalton">Andy Dalton</a> inked a <a href="https://www.spotrac.com/nfl/new-orleans-saints/andy-dalton-7750/" target="_blank" rel="noopener noreferrer">one-year, $3 million</a> deal with the Saints this offseason—while career backups and incoming rookies are.</p><p class="">Expect a team to sign Foles only after evaluating what it has at quarterback. That might not happen until the preseason is underway, though an injury could speed up the process.</p></ol></div><div class="organism contentStream slide" id="slide5"><div class="ad"><div class="lazy br-ad-wrapper atom advert"><div id="br-ad-2955993-5" class="br-ad-lazy" data-collapsed="0" data-country="US" data-position="rect_atf_03" data-reload="1" data-responsive-size="[[[970,0],[&quot;fluid&quot;,[970,250],[970,66],[728,90],[300,250]]],[[728,0],[&quot;fluid&quot;,[728,90],[300,250]]],[[0,0],[&quot;fluid&quot;,[300,250],[320,50]]]]" data-size="[[300,600],[300,250],[300,2]]"></div></div></div><h1>CB Joe Haden</h1><div class="slideData">5 of 8</div><ol><div class="atom photo" itemscope="" itemType="http://schema.org/ImageObject"><p></p><div class="imgWrapper"><div class="atom articleLeadImage blurUp"><img alt="" src="https://media.bleacherreport.com/w_40,h_27,c_fill/br-img-slides/004/517/595/421e371b104631a348cea75dbb9a7162_crop_exact.jpg" itemProp="contentUrl"/></div></div><small><span class="caption"></span><span itemProp="citation" class="credit">Icon Sportswire/Getty Images</span></small></div><p class="">Cornerback Joe Haden might be 33 years old and coming off a down season—he allowed an opposing quarterback rating of <a href="https://www.pro-football-reference.com/players/H/HadeJo99.htm#detailed_defense" target="_blank" rel="noopener noreferrer">100.1</a> in 2021—but the three-time Pro Bowler is respected by his peers. Buffalo Bills pass-rusher Von Miller, for example, <a href="https://billswire.usatoday.com/2022/04/21/von-miller-recruiting-joe-haden-buffalo-bills-brandon-beane/" target="_blank" rel="noopener noreferrer">tried to recruit</a> Haden to his new team.</p><p class="">&quot;We definitely talked about Buffalo, we definitely talked about him coming here. I don&apos;t know what the holdup is,&quot; Miller told reporters.</p><p class="">The &quot;holdup&quot; is likely a two-pronged entity. At his age, Haden probably isn&apos;t interested in battling for a roster spot in minicamps and OTAs. He won&apos;t be viewed as a long-term answer either, which means teams will assess what they have in younger players, including rookies, before turning to someone who&apos;s likely nearing the end of his career.</p><p class="">It&apos;s also worth noting that several younger veteran cornerbacks—including Trae Waynes (29), Kyle Fuller (30), Vernon Hargreaves III (26) and Mackensie Alexander (28)—are still available. Moving on Haden won&apos;t be a priority because the market isn&apos;t bone-dry.</p><p class="">However, it will be a major surprise if Haden isn&apos;t picked up during early training camp. He has 148 career starts—including 11 in 2021—and can start in 2022.</p></ol></div><div class="organism contentStream slide" id="slide6"><div class="ad"><div class="lazy br-ad-wrapper atom advert"><div id="br-ad-2955993-6" class="br-ad-lazy" data-collapsed="0" data-country="US" data-position="rect_atf_03" data-reload="1" data-responsive-size="[[[970,0],[&quot;fluid&quot;,[970,250],[970,66],[728,90],[300,250]]],[[728,0],[&quot;fluid&quot;,[728,90],[300,250]]],[[0,0],[&quot;fluid&quot;,[300,250],[320,50]]]]" data-size="[[300,600],[300,250],[300,2]]"></div></div></div><h1>Edge Jerry Hughes</h1><div class="slideData">6 of 8</div><ol><div class="atom photo" itemscope="" itemType="http://schema.org/ImageObject"><p></p><div class="imgWrapper"><div class="atom articleLeadImage blurUp"><img alt="" src="https://media.bleacherreport.com/w_40,h_27,c_fill/br-img-slides/004/517/596/23f98cb7e8cc8e0d750e60e34a841969_crop_exact.jpg" itemProp="contentUrl"/></div></div><small><span class="caption"></span><span itemProp="citation" class="credit">Icon Sportswire/Getty Images</span></small></div><p class="">Jerry Hughes is now a complementary pass-rusher, albeit a valuable one. He only logged two sacks with Buffalo last season but produced <a href="https://www.pro-football-reference.com/players/H/HughJe99.htm" target="_blank" rel="noopener noreferrer">26</a> quarterback pressures while playing 52 percent of the defensive snaps.</p><p class="">The 12-year veteran, who will turn 34 in August, has drawn interest this offseason. The Cleveland Browns, for example, have eyed Hughes, according to <a href="https://www.cleveland.com/browns/2022/04/baker-mayfield-drawing-trade-interest-from-a-handful-of-teams-as-the-nfl-draft-kicks-off-thursday-browns-insider.html" target="_blank" rel="noopener noreferrer">Mary Kay Cabot</a> of Cleveland.com. The Browns, though, will presumably try to re-sign free-agent pass-rusher <a href="http://bleacherreport.com/jadeveon-clowney">Jadeveon Clowney</a> before turning to an aging vet like Hughes.</p><p class="">Clowney is 29 years old and is coming off a nine-sack season.</p><p class="">The presence of guys like Clowney, Jason Pierre-Paul, Carl Nassib and Melvin Ingram on the market means a team has little reason to immediately move on Hughes. He can be a significant contributor, but other edge-rushing options are available.</p><p class="">Expect Hughes to land with a team only after in-house talent is further vetted and after the veteran pass-rusher market picks back up.</p></ol></div><div class="organism contentStream slide" id="slide7"><div class="ad"><div class="lazy br-ad-wrapper atom advert"><div id="br-ad-2955993-7" class="br-ad-lazy" data-collapsed="0" data-country="US" data-position="rect_atf_03" data-reload="1" data-responsive-size="[[[970,0],[&quot;fluid&quot;,[970,250],[970,66],[728,90],[300,250]]],[[728,0],[&quot;fluid&quot;,[728,90],[300,250]]],[[0,0],[&quot;fluid&quot;,[300,250],[320,50]]]]" data-size="[[300,600],[300,250],[300,2]]"></div></div></div><h1>WR Julio Jones</h1><div class="slideData">7 of 8</div><ol><div class="atom photo" itemscope="" itemType="http://schema.org/ImageObject"><p></p><div class="imgWrapper"><div class="atom articleLeadImage blurUp"><img alt="" src="https://media.bleacherreport.com/w_40,h_27,c_fill/br-img-slides/004/517/594/389dbcc22acb69c1cd53ff6de145db6a_crop_exact.jpg" itemProp="contentUrl"/></div></div><small><span class="caption"></span><span itemProp="citation" class="credit">Joe Sargent/Getty Images</span></small></div><p class="">If not for his age (33) and injury struggles, there&apos;s virtually no chance receiver <a href="http://bleacherreport.com/julio-jones">Julio Jones</a> would still be available. The seven-time Pro Bowler is a future Hall of Famer but has been limited by hamstring injuries over the past two seasons.</p><p class="">In the Titans&apos; run-oriented offense, Jones had just 434 yards and a touchdown in 10 games in 2021.</p><p class="">Because Jones has struggled to stay healthy, his next team won&apos;t be incentivized to work him in camp or play him in the preseason. It will want the 11-year veteran as healthy and as fresh as possible for the games that matter.</p><p class="">There isn&apos;t much need to get Jones under contract before camp. Even as a late addition, he will carry some injury risk. Expect a team to move on Jones only after concluding that its receiving corps isn&apos;t deep or talented enough.</p><p class="">Still, it will be a major shock to not see Jones play in 2022. Two years ago with the Atlanta Falcons, he only played in nine games but finished with 771 receiving yards and three touchdowns while providing a passer rating of <a href="https://www.pro-football-reference.com/players/J/JoneJu02.htm" target="_blank" rel="noopener noreferrer">126.5</a> when targeted.</p></ol></div><div class="organism contentStream slide" id="slide8"><div class="ad"><div class="lazy br-ad-wrapper atom advert"><div id="br-ad-2955993-8" class="br-ad-lazy" data-collapsed="0" data-country="US" data-position="rect_atf_03" data-reload="1" data-responsive-size="[[[970,0],[&quot;fluid&quot;,[970,250],[970,66],[728,90],[300,250]]],[[728,0],[&quot;fluid&quot;,[728,90],[300,250]]],[[0,0],[&quot;fluid&quot;,[300,250],[320,50]]]]" data-size="[[300,600],[300,250],[300,2]]"></div></div></div><h1>DT Larry Ogunjobi</h1><div class="slideData">8 of 8</div><ol><div class="atom photo" itemscope="" itemType="http://schema.org/ImageObject"><p></p><div class="imgWrapper"><div class="atom articleLeadImage blurUp"><img alt="" src="https://media.bleacherreport.com/w_40,h_27,c_fill/br-img-slides/004/517/598/1e040b401bd9b98d7dd014e52cc11962_crop_exact.jpg" itemProp="contentUrl"/></div></div><small><span class="caption"></span><span itemProp="citation" class="credit">Icon Sportswire/Getty Images</span></small></div><p class="">If not for injury, defensive tackle Larry Ogunjobi wouldn&apos;t<em> </em>be available. The Bears offered Ogunjobi a three-year, $40.5 million deal at the onset of free agency but <a href="https://www.espn.com/nfl/story/_/id/33536218/chicago-bears-not-signing-larry-ogunjobi-failed-physical" target="_blank" rel="noopener noreferrer">voided</a> the deal after a failed physical.</p><p class="">Ogunjobi suffered a foot injury that required surgery early in the Cincinnati Bengals&apos; surprising postseason run.</p><p class="">Before the injury, though, he was a breakout star. While he had four promising seasons with the Browns before joining Cincinnati, the 27-year-old was a difference-maker with the Bengals. He finished the 2021 season with 49 tackles, seven sacks and <a href="https://www.pro-football-reference.com/players/O/OgunLa00.htm" target="_blank" rel="noopener noreferrer">24</a> quarterback pressures. If healthy, he&apos;ll be an instant-impact starter wherever he lands.</p><p class="">Ogunjobi will land on a 2022 roster but might not join a team until training camp. The more recovery time he is afforded, the more likely he is to clear any medical checks a new contract will require.</p><p class="">In Ogunjobi&apos;s case, teams are likely to play the waiting game. In theory, a franchise can give him three more months of recovery and still make him an early-camp addition. That franchise might even be Chicago, which <a href="https://www.audacy.com/670thescore/sports/chicago-bears/ryan-poles-leaves-open-possibility-bears-could-sign-larry-ogunjobi" target="_blank" rel="noopener noreferrer">hasn&apos;t ruled out</a> trying again to sign the five-year veteran.</p><p class="">         </p><p class=""><em>Advanced statistics from <a href="https://www.pro-football-reference.com/" target="_blank" rel="noopener noreferrer">Pro Football Reference</a> unless otherwise noted. </em></p></ol></div></div></div><form class="cell newsletterSubsModule flyIn"><div class="container"><h5 class="headline">🚨 SPORTS NEWS ➡️ YOUR INBOX</h5><br/><p class="subheading">The latest in the sports world, emailed daily.</p><br/><div class="input-and-submit-btn"><input type="email" placeholder="Email address" class=""/><button class="atom button" type="submit">Join Newsletter</button></div><button class="atom button dismiss" type="button">Maybe later</button></div></form><div class="footer-wrapper" style="margin-top:2em"><footer><div class="atom share"><ul><li class="shareFacebook" title="Share this article on Facebook"><svg class="atom icon svg facebook" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 10 16"><title>Facebook Logo</title><path d="M6.24 16V8.7h2.45l.365-2.842H6.24V4.04c0-.822.227-1.384 1.41-1.384h1.5V.112C8.42.035 7.686-.002 6.953 0 4.79 0 3.3 1.325 3.3 3.76v2.098H.846V8.7H3.3V16h2.94z"></path></svg></li><li class="shareTwitter" title="Share this article on Twitter"><svg class="atom icon svg twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 14"><title>Twitter Logo</title><path d="M5.042 13.504c6.01 0 9.3-4.985 9.3-9.3 0-.14 0-.28-.006-.42.638-.46 1.192-1.04 1.632-1.697-.586.262-1.217.434-1.88.517.675-.402 1.192-1.046 1.44-1.81-.63.375-1.332.643-2.078.79C12.85.946 12.003.55 11.066.55c-1.804 0-3.27 1.467-3.27 3.27 0 .256.032.505.083.747-2.717-.134-5.126-1.44-6.74-3.417C.86 1.635.7 2.196.7 2.795c0 1.134.58 2.135 1.455 2.722-.536-.02-1.04-.166-1.48-.408v.043c0 1.58 1.13 2.907 2.62 3.207-.273.076-.56.115-.86.115-.21 0-.414-.02-.612-.058.414 1.3 1.626 2.244 3.053 2.27-1.12.88-2.53 1.402-4.06 1.402-.26 0-.523-.014-.778-.046 1.44.918 3.162 1.46 5.004 1.46"></path></svg></li><li class="shareLink" title="Copy this link to your clipboard"><svg class="atom icon svg link" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20 10"><title>Copy Link Icon</title><path d="M1.9 5c0-1.71 1.39-3.1 3.1-3.1h4V0H5C2.24 0 0 2.24 0 5s2.24 5 5 5h4V8.1H5C3.29 8.1 1.9 6.71 1.9 5zM6 6h8V4H6v2zm9-6h-4v1.9h4c1.71 0 3.1 1.39 3.1 3.1 0 1.71-1.39 3.1-3.1 3.1h-4V10h4c2.76 0 5-2.24 5-5s-2.24-5-5-5z"></path></svg></li></ul></div><div></div></footer><div class="atom outbrain OUTBRAIN" data-src="https://bleacherreport.com/articles/2955993" data-widget-id="AR_8" data-ob-template="BleacherReport_1"></div></div><div class="fixedRegion"><div class="atom stickyAdvert hide"><div class="ad"><div id="closeAd" class="close">X</div><div class="br-ad-wrapper atom advert"><div id="br-ad-ba5" class="br-ad" data-collapsed="0" data-country="US" data-position="bnr_atf_05" data-reload="2" data-responsive-size="[[[1280,0],[&quot;fluid&quot;,[1280,100],[728,90]]],[[728,0],[&quot;fluid&quot;,[728,90]]],[[0,0],[&quot;fluid&quot;,[320,50]]]]" data-size="[[320,50],[728,90],[1280,100]]"></div></div></div></div></div></article></div><div id="ad-skin-measurability-r" class="ad-rail"></div></div><div class="adsContainer"></div><footer class="molecule footer"><div><svg class="atom logo svg brPlateLight" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 1600 1200"><title>Bleacher Report Logo</title><g><rect width="1600" height="1200" fill="#fff"></rect><path fill="#000" d="M484.85 200H200v800h284.85L600 884.85v-229.7L544.85 600 600 544.85v-229.7zM320 540V320h115.15L480 364.85v130.3L435.15 540zm115.15 120L480 704.85v130.3L435.15 880H320V660zM1415 1000l-99.35-370.79 84.35-84.36v-229.7L1284.85 200H1000v800h120V660h83.9l91.1 340zm-295-680h115.15l44.85 44.85v130.3L1235.15 540H1120zM700 770.71l200-200V429.29l-200 200v141.42z"></path></g></svg><form class="cell newsletterSubsModule inline footer"><div class="container"><h5 class="headline">🚨 SPORTS NEWS ➡️ YOUR INBOX</h5><br/><p class="subheading">The latest in the sports world, emailed daily.</p><br/><div class="input-and-submit-btn"><input type="email" placeholder="Email address" class=""/><button class="atom button" type="submit">Join Newsletter</button></div></div></form><ul class="social"><li><a href="https://facebook.com/bleacherreport/"><svg class="atom icon svg facebookFilled" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 267 267"><title>Facebook Logo</title><path d="M252.16,0H14.73A14.73,14.73,0,0,0,0,14.73V252.16a14.73,14.73,0,0,0,14.73,14.73H142.56V163.54H107.78V123.26h34.78V93.55c0-34.47,21.05-53.24,51.81-53.24a285.37,285.37,0,0,1,31.08,1.59v36H204.12c-16.72,0-20,7.95-20,19.61v25.72H224l-5.19,40.28H184.15V266.89h68a14.73,14.73,0,0,0,14.73-14.73V14.73A14.73,14.73,0,0,0,252.16,0Z"></path></svg></a></li><li><a href="https://twitter.com/bleacherreport/"><svg class="atom icon svg twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 14"><title>Twitter Logo</title><path d="M5.042 13.504c6.01 0 9.3-4.985 9.3-9.3 0-.14 0-.28-.006-.42.638-.46 1.192-1.04 1.632-1.697-.586.262-1.217.434-1.88.517.675-.402 1.192-1.046 1.44-1.81-.63.375-1.332.643-2.078.79C12.85.946 12.003.55 11.066.55c-1.804 0-3.27 1.467-3.27 3.27 0 .256.032.505.083.747-2.717-.134-5.126-1.44-6.74-3.417C.86 1.635.7 2.196.7 2.795c0 1.134.58 2.135 1.455 2.722-.536-.02-1.04-.166-1.48-.408v.043c0 1.58 1.13 2.907 2.62 3.207-.273.076-.56.115-.86.115-.21 0-.414-.02-.612-.058.414 1.3 1.626 2.244 3.053 2.27-1.12.88-2.53 1.402-4.06 1.402-.26 0-.523-.014-.778-.046 1.44.918 3.162 1.46 5.004 1.46"></path></svg></a></li><li><a href="https://instagram.com/bleacherreport/"><svg class="atom icon svg instagram" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><title>Instagram Logo</title><g><path d="M11.816 5.744c-3.353 0-6.072 2.72-6.072 6.072 0 3.353 2.72 6.072 6.072 6.072 3.353 0 6.072-2.72 6.072-6.072 0-1.61-.64-3.155-1.778-4.294-1.14-1.138-2.684-1.778-4.294-1.778zm0 10.016c-2.178 0-3.944-1.766-3.944-3.944s1.766-3.944 3.944-3.944 3.944 1.766 3.944 3.944-1.766 3.944-3.944 3.944z"></path><circle cx="18.128" cy="5.52" r="1.416"></circle><path d="M23.024 4.08c-.614-1.587-1.87-2.842-3.456-3.456-.92-.345-1.89-.532-2.872-.552C15.432.016 15.032 0 11.824 0S8.208 0 6.952.072C5.97.092 5 .28 4.08.624 2.493 1.238 1.238 2.494.624 4.08.28 5 .092 5.97.072 6.952.016 8.216 0 8.616 0 11.824s0 3.616.072 4.872c.02.982.207 1.953.552 2.872.614 1.587 1.87 2.842 3.456 3.456.917.36 1.888.56 2.872.592 1.264.056 1.664.072 4.872.072s3.616 0 4.872-.072c.982-.02 1.953-.207 2.872-.552 1.587-.614 2.842-1.87 3.456-3.456.345-.92.532-1.89.552-2.872.056-1.264.072-1.664.072-4.872s0-3.616-.072-4.872c-.016-.995-.202-1.98-.552-2.912zm-1.6 12.52c-.007.757-.145 1.506-.408 2.216-.398 1.033-1.215 1.85-2.248 2.248-.702.26-1.443.398-2.192.408-1.248.056-1.6.072-4.8.072-3.2 0-3.528 0-4.8-.072-.75-.01-1.49-.148-2.192-.408-1.037-.395-1.857-1.213-2.256-2.248-.26-.702-.398-1.443-.408-2.192-.056-1.248-.072-1.6-.072-4.8 0-3.2 0-3.528.072-4.8.007-.757.145-1.506.408-2.216.4-1.035 1.22-1.853 2.256-2.248.702-.26 1.443-.398 2.192-.408 1.248-.056 1.6-.072 4.8-.072 3.2 0 3.528 0 4.8.072.75.01 1.49.148 2.192.408 1.033.398 1.85 1.215 2.248 2.248.26.702.398 1.443.408 2.192.056 1.248.072 1.6.072 4.8 0 3.2 0 3.544-.056 4.8h-.016z"></path></g></svg></a></li></ul><ul class="links"><li><a href="/pages/about">About</a></li><li><a href="/pages/advertise">Advertise</a></li><li><a href="/pages/contact">Contact Us</a></li><li><a href="https://support.bleacherreport.com/">Get Help</a></li><li><a href="https://careers.bleacherreport.com/">Careers</a></li><li><a href="/pages/comguidelines">Community Guidelines</a></li><li><a href="https://www.warnermediaprivacy.com/policycenter/b2c/WMNS/">Privacy</a></li><li><a href="#">Do Not Sell My Personal Information</a></li><li><a href="/pages/terms">Terms Of Use</a></li><li><a href="https://www.stubhub.com/?gcid=chAFF-_-geoUS-_-genAllTix-_-dt170312-_-cmpBR_footr-_-partBleacherReport">Tickets</a></li><li><a href="https://www.warnermediaprivacy.com/opt-out/" target="_blank" rel="noopener noreferrer">AdChoices <img src="https://static-assets.bleacherreport.net/img/molecules/footer/adChoices.png" width="12" height="12" alt="" role="presentation" style="vertical-align:middle"/></a></li></ul></div><small class="copyright">
  Copyright © 2022 Bleacher Report, Inc. Turner Broadcasting System, Inc.
  All Rights Reserved.
  BleacherReport.com is part of Bleacher Report – Turner Sports Network, part of the Turner Sports and Entertainment Network.
<!-- -->
  Certain photos copyright © 2022 Getty Images.
  Any commercial use or distribution without the express written consent of Getty Images is strictly prohibited.
<a href="https://www.warnermediaprivacy.com/opt-out/" target="_blank" rel="noopener noreferrer">AdChoices <img src="https://static-assets.bleacherreport.net/img/molecules/footer/adChoices.png" width="12" height="12" alt="" role="presentation" style="vertical-align:middle"/></a></small><svg class="atom logo svg turner" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 601.7 105.2"><title>Turner Logo</title><path d="M502.3 63.5c1.7-7.2 2.7-13.3 2.7-19.3C505 19.6 488.5.1 460.5.1 430 .1 405.7 22.9 401 52.6c-5 31.5 14.3 52.5 44.2 52.5 23.6 0 43.5-13.3 53.7-33.5h-36.1c-4.5 4.7-10.5 6-15.7 5.9-10.4-.2-15.3-6.3-15.4-14h70.6zm-43.7-36.9c9.2 0 15.4 5.8 15.1 14.5h-37c3.5-8.5 11.8-14.5 21.9-14.5zM579 .6c-12.5 0-22.8 10.2-22.8 22.6 0 12.6 10.3 22.9 22.8 22.9 12.6 0 22.9-10.3 22.7-22.9C601.9 10.7 591.6.6 579 .6zM364.9 0c-11.4 0-25.3 6.9-32 16l3.8-13.4h-32.4l-17.7 100.2h34.8l10-56.7c1.7-9.4 9-15.9 17.7-15.9 8.4 0 12.4 6.9 10.9 15.9l-10 56.7h34.8l10.9-61.5C400.1 16 387.8 0 364.9 0zM5.7 2.6h91.6l-5.7 32.2H63.8l-12 67.9H17l12-67.9H0M105.3 2.6h34.8l-9.8 55.7c-1.7 9.6 2.7 15.3 11.2 15.3 8.7 0 15.5-6 17.2-15.3l9.8-55.7h34.8L193.9 56c-6 33.4-27.7 49-56.9 49-29.8 0-46.9-16.3-41.1-49.2l9.4-53.2zM194.6 102.7h34.7L247 2.6h-34.8M270.2.6c-12.4 0-22.8 10.2-22.8 22.6 0 12.6 10.3 22.9 22.8 22.9 12.6 0 22.9-10.3 22.8-22.9.1-12.5-10.2-22.6-22.8-22.6zM503.3 102.7H538L555.7 2.6h-34.8"></path></svg></footer></div></div></div><script id="__LOADABLE_REQUIRED_CHUNKS__" type="application/json">[]</script><script async="" data-chunk="bundle" src="https://static-assets.bleacherreport.net/js/vendor-62ad46b3.js"></script><script async="" data-chunk="bundle" src="https://static-assets.bleacherreport.net/js/bundle.335b13f357984d923a3aeaea9dd5fe60.js"></script><div id="pixels"></div><div id="infogram-async"></div><div><!-- Generated on 05/07/22 at 02:27 PM --></div></body></html>