<!DOCTYPE html><html class="no-js" lang="en" data-reactroot=""><head><meta charSet="utf-8"/><meta http-equiv="Accept-CH" content="DPR,Width,Viewport-Width"/><meta name="aol-te-auth" content="1c424580-0f86-4d9b-88b2-bc8c0d029d4c"/><meta name="blitz" content="mu-6e4ce5cd-57f20d11-7c0ecee9-d55c79e2"/><meta name="msvalidate.01" content="7A63840181953B2A5A1FEA25FB45A991"/><meta name="robots" content="NOODP,NOYDIR"/><meta name="verify-v1" content="+Ntj422Jc4V03qgBqLYbF3LMvrursV0X2btn2Zoqn9w="/><meta name="description" content="The Green Bay Packers continue to roll.      Green Bay moved to 3-0 on the season with a 37-30 victory over the New Orleans Saints on Sunday at Mercedes-Benz Superdome..."/><meta name="viewport" content="width=device-width, initial-scale=1"/><meta property="fb:app_id" content="135174055162"/><meta name="al:iphone:url" content="teamstream://article/bleacherreport.com/articles/2910904-aaron-rodgers-packers-defeat-drew-brees-saints-despite-alvin-kamaras-2-tds"/><meta name="al:iphone:app_store_id" content="418075935"/><meta name="al:iphone:app_name" content="Bleacher Report"/><meta name="al:ipad:url" content="teamstream://article/bleacherreport.com/articles/2910904-aaron-rodgers-packers-defeat-drew-brees-saints-despite-alvin-kamaras-2-tds"/><meta name="al:ipad:app_store_id" content="484725748"/><meta name="al:ipad:app_name" content="Bleacher Report"/><meta name="al:android:url" content="https://bleacherreport.com/articles/2910904-aaron-rodgers-packers-defeat-drew-brees-saints-despite-alvin-kamaras-2-tds"/><meta name="al:android:app_name" content="Bleacher Report"/><meta name="al:android:package" content="com.bleacherreport.android.teamstream"/><meta name="al:web:url" content="https://bleacherreport.com/articles/2910904-aaron-rodgers-packers-defeat-drew-brees-saints-despite-alvin-kamaras-2-tds"/><meta property="og:site_name" content="Bleacher Report"/><meta property="og:locale" content="en_US"/><meta name="p:domain_verify" content="0c768466449ebb550411234d6d4ffc30"/><meta name="theme-color" content="#000"/><meta name="twitter:app:name:iphone" content="Bleacher Report"/><meta name="twitter:app:id:iphone" content="418075935"/><meta name="twitter:app:name:ipad" content="Bleacher Report"/><meta name="twitter:app:id:ipad" content="484725748"/><meta name="twitter:app:name:googleplay" content="Bleacher Report"/><meta name="twitter:app:id:googleplay" content="com.bleacherreport.android.teamstream"/><meta name="twitter:widgets:new-embed-design" content="on"/><meta name="twitter:site" content="@bleacherreport"/><meta name="article:publisher" content="https://www.facebook.com/bleacherreport"/><meta name="author" content="Scott Polacek"/><meta property="og:description" content="The Green Bay Packers continue to roll.      Green Bay moved to 3-0 on the season with a 37-30 victory over the New Orleans Saints on Sunday at Mercedes-Benz Superdome..."/><meta property="og:image" content="https://img.bleacherreport.net/img/images/photos/003/886/052/hi-res-e19a58ef141f3fc44156ae8cdebc4f24_crop_exact.jpg?w=1200&amp;h=1200&amp;q=75"/><meta property="og:title" content="Aaron Rodgers, Packers Defeat Drew Brees, Saints Despite Alvin Kamara&#x27;s 2 TDs"/><meta property="og:type" content="article"/><meta property="og:url" content="https://bleacherreport.com/articles/2910904-aaron-rodgers-packers-defeat-drew-brees-saints-despite-alvin-kamaras-2-tds"/><meta name="pubdate" content="2020-09-27T23:37:50-04:00"/><meta name="thumbnail" content="https://img.bleacherreport.net/img/images/photos/003/886/052/hi-res-e19a58ef141f3fc44156ae8cdebc4f24_crop_exact.jpg?w=1200&amp;h=1200&amp;q=75"/><meta name="twitter:app:url:googleplay" content="https://bleacherreport.com/articles/2910904-aaron-rodgers-packers-defeat-drew-brees-saints-despite-alvin-kamaras-2-tds"/><meta name="twitter:app:url:ipad" content="teamstream://article/bleacherreport.com/articles/2910904-aaron-rodgers-packers-defeat-drew-brees-saints-despite-alvin-kamaras-2-tds"/><meta name="twitter:app:url:iphone" content="teamstream://article/bleacherreport.com/articles/2910904-aaron-rodgers-packers-defeat-drew-brees-saints-despite-alvin-kamaras-2-tds"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:description" content="The Green Bay Packers continue to roll.      Green Bay moved to 3-0 on the season with a 37-30 victory over the New Orleans Saints on Sunday at Mercedes-Benz Superdome..."/><meta name="twitter:image" content="https://img.bleacherreport.net/img/images/photos/003/886/052/hi-res-e19a58ef141f3fc44156ae8cdebc4f24_crop_exact.jpg?w=1200&amp;h=1200&amp;q=75"/><meta name="twitter:title" content="Aaron Rodgers, Packers Defeat Drew Brees, Saints Despite Alvin Kamara&#x27;s 2 TDs"/><meta name="twitter:url" content="https://bleacherreport.com/articles/2910904-aaron-rodgers-packers-defeat-drew-brees-saints-despite-alvin-kamaras-2-tds"/><link rel="shortcut icon" href="https://static-assets.bleacherreport.net/favicon.ico"/><title>Aaron Rodgers, Packers Defeat Drew Brees, Saints Despite Alvin Kamara&#x27;s 2 TDs | Bleacher Report | Latest News, Videos and Highlights</title><script src="//d1je72vo6cxqo9.cloudfront.net/script.js" async="" id="rwxsawuta"></script><script type="text/javascript">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</script><link rel="stylesheet" type="text/css" href="https://static-assets.bleacherreport.net/css/articlePage.critical.60ec65283706f31ae8b2.css" crossorigin="anonymous" class="" media="all"/><link rel="stylesheet" type="text/css" href="https://static-assets.bleacherreport.net/css/global.538e0c04fd8d4403636b.css" crossorigin="anonymous" class="preload-css" media="print"/><link rel="stylesheet" type="text/css" href="https://static-assets.bleacherreport.net/css/atomic.d8bc8c21953d5a7d351e.css" crossorigin="anonymous" class="preload-css" media="print"/><link rel="stylesheet" type="text/css" href="https://cdn.bitmovin.com/player/web/8.10.1/bitmovinplayer-ui.css" crossorigin="anonymous" class="" media="all"/><script src="//d1je72vo6cxqo9.cloudfront.net/script.js" async="" id="rwxsawuta"></script><script src="https://static-assets.bleacherreport.net/js/registerServiceWorker.js" async="" id="registerServiceWorkerJS"></script><script type="application/ld+json">{"@context":"http://schema.org","@type":"NewsArticle","about":"The Green Bay Packers continue to roll.      Green Bay moved to 3-0 on the season with a 37-30 victory over the New Orleans Saints on Sunday at Mercedes-Benz Superdome...","author":{"@type":"Person","name":"Scott Polacek","jobTitle":"Featured Columnist"},"dateModified":"2020-09-28T00:07:31-04:00","datePublished":"2020-09-27T23:37:50-04:00","description":"The Green Bay Packers continue to roll.      Green Bay moved to 3-0 on the season with a 37-30 victory over the New Orleans Saints on Sunday at Mercedes-Benz Superdome...","headline":"Aaron Rodgers, Packers Defeat Drew Brees, Saints Despite Alvin Kamara's 2 TDs","image":{"type":"ImageObject","url":"https://img.bleacherreport.net/img/images/photos/003/886/052/hi-res-e19a58ef141f3fc44156ae8cdebc4f24_crop_exact.jpg?w=900&h=600&q=75"},"inLanguage":"English","isFamilyFriendly":true,"keywords":"NFL,Aaron_Rodgers,Drew_Brees,Breaking_News,Alvin_Kamara,BNT_NFL","mainEntityOfPage":"The Green Bay Packers continue to roll.      Green Bay moved to 3-0 on the season with a 37-30 victory over the New Orleans Saints on Sunday at Mercedes-Benz Superdome...","publisher":{"@type":"Organization","name":"Bleacher Report","url":"https://bleacherreport.com","logo":{"type":"ImageObject","url":"https://static-assets.bleacherreport.net/img/br_60_height.png","width":"80","height":"60"}},"thumbnailURL":"https://img.bleacherreport.net/img/images/photos/003/886/052/hi-res-e19a58ef141f3fc44156ae8cdebc4f24_crop_exact.jpg?w=900&h=600&q=75"}</script><link rel="manifest" type="" href="/manifest.json" crossorigin="anonymous" class="" media="all"/><link rel="mask-icon" type="" href="/img/favicon/safariMaskIcon.svg" color="#000000" crossorigin="anonymous" class="" media="all"/><link rel="apple-touch-icon" type="" href="/img/favicon/appleTouchIcon.png" sizes="180x180" crossorigin="anonymous" class="" media="all"/><link rel="icon" type="" href="/img/favicon/favicon32.png" sizes="32x32" crossorigin="anonymous" class="" media="all"/><link rel="icon" type="" href="/img/favicon/favicon16.png" sizes="16x16" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://ib.adnxs.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://prebid.adnxs.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://secure.adnxs.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://fastlane.rubiconproject.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://optimized-by.rubiconproject.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://ads.rubiconproject.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://fastlane-adv.rubiconproject.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://aax.amazon-adsystem.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://c.amazon-adsystem.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://bidder.criteo.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://static.criteo.net" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://js-sec.indexww.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://as-sec.casalemedia.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://observe.aniview.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://mcdp-chidc2.outbrain.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://log.outbrainimg.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://videoclientsservicescalls.outbrain.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://e.infogr.am" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://serv.vid-play.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://servt.vid-play.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://track.aniview.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://pistyll.bleacherreport.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://geo.moatads.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://preferences.truste.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://vis.vi-serve.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://t.vi-serve.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://s.vi-serve.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://secure-us.imrworldwide.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://www.facebook.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://connect.facebook.net" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://pixel.adsafeprotected.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://www.instagram.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://platform.instagram.com" crossorigin="anonymous" class="" media="all"/><link rel="dns-prefetch" type="" href="https://tags.tiqcdn.com" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/proxima-nova/proxima-nova-regular.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/proxima-nova/proxima-nova-regular-italic.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/proxima-nova/proxima-nova-medium.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/proxima-nova/proxima-nova-bold.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/effra/effra-regular.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/effra/effra-medium.woff2" crossorigin="anonymous" class="" media="all"/><link as="font" rel="preload" type="" href="https://static-assets.bleacherreport.net/fonts/effra/effra-bold.woff2" crossorigin="anonymous" class="" media="all"/><link rel="amphtml" type="" href="https://syndication.bleacherreport.com/amp/2910904-aaron-rodgers-packers-defeat-drew-brees-saints-despite-alvin-kamaras-2-tds.amp.html" crossorigin="anonymous" class="" media="all"/><link rel="alternate" type="" href="android-app://com.bleacherreport.android.teamstream/http/bleacherreport.com/articles/2910904-aaron-rodgers-packers-defeat-drew-brees-saints-despite-alvin-kamaras-2-tds" crossorigin="anonymous" class="" media="all"/><link rel="alternate" type="" href="android-app://com.bleacherreport.android.teamstream/teamstream/article/bleacherreport.com/articles/2910904-aaron-rodgers-packers-defeat-drew-brees-saints-despite-alvin-kamaras-2-tds" crossorigin="anonymous" class="" media="all"/><link rel="alternate" type="" href="ios-app://418075935/http/bleacherreport.com/articles/2910904-aaron-rodgers-packers-defeat-drew-brees-saints-despite-alvin-kamaras-2-tds" crossorigin="anonymous" class="" media="all"/><link rel="canonical" type="" href="https://bleacherreport.com/articles/2910904-aaron-rodgers-packers-defeat-drew-brees-saints-despite-alvin-kamaras-2-tds" crossorigin="anonymous" class="" media="all"/><link rel="alternate" type="application/json+oembed" href="https://bleacherreport.com/oembed?url=https%3A%2F%2Fbleacherreport.com%2Farticles%2F2910904-aaron-rodgers-packers-defeat-drew-brees-saints-despite-alvin-kamaras-2-tds" crossorigin="anonymous" class="" media="all"/><link rel="alternate" type="application/xml+oembed" href="https://bleacherreport.com/oembed?url=https%3A%2F%2Fbleacherreport.com%2Farticles%2F2910904-aaron-rodgers-packers-defeat-drew-brees-saints-despite-alvin-kamaras-2-tds&amp;format=xml" crossorigin="anonymous" class="" media="all"/></head><body><div id="app"><div class="template website light"><div class="fixedRegion"></div><header><div class="nav organism"><a id="br-logo" class="siteLogo" href="/"><svg class="atom logo svg br" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 1600 1200"><title>Bleacher Report Logo</title><g><path d="M484.85 200H200v800h284.85L600 884.85v-229.7L544.85 600 600 544.85v-229.7zM320 540V320h115.15L480 364.85v130.3L435.15 540zm115.15 120L480 704.85v130.3L435.15 880H320V660zM1415 1000l-99.35-370.79 84.35-84.36v-229.7L1284.85 200H1000v800h120V660h83.9l91.1 340zm-295-680h115.15l44.85 44.85v130.3L1235.15 540H1120zM700 770.71l200-200V429.29l-200 200v141.42z"></path></g></svg></a><nav id="league-links"><ol class="molecule nav-list"><li class="atom nav-link parent-link top-level" id="nfl"><a href="/nfl">NFL</a></li><li class="atom nav-link parent-link top-level" id="nba"><a href="/nba">NBA</a></li><li class="atom nav-link parent-link top-level" id="college-football"><a href="/college-football">CFB</a></li><li class="atom nav-link parent-link top-level" id="world-football"><a href="/world-football">World Football</a></li><li class="atom nav-link parent-link top-level" id="mlb"><a href="/mlb">MLB</a></li><li class="atom nav-link parent-link top-level" id="nhl"><a href="/nhl">NHL</a></li><li class="atom nav-link parent-link top-level" id="college-basketball"><a href="/college-basketball">CBB</a></li><li class="atom nav-link top-level" id="mma"><a href="/mma">MMA</a></li><li class="atom nav-link top-level" id="all-elite-wrestling"><a href="/all-elite-wrestling">AEW</a></li><li class="atom nav-link top-level" id="wwe"><a href="/wwe">WWE</a></li><li class="atom nav-link top-level" id="wnba"><a href="/wnba">WNBA</a></li><li class="atom nav-link top-level" id="golf"><a href="/golf">Golf</a></li><li class="atom nav-link top-level" id="tennis"><a href="/tennis">Tennis</a></li><li class="atom nav-link top-level" id="boxing"><a href="/boxing">Boxing</a></li><li class="atom nav-link top-level" id="https://bleacherreportshop.com/?utm_source=Bleacher%20Report&amp;utm_medium=referral&amp;utm_campaign=Bleacher%20Report%20Website%20Menu"><a href="https://bleacherreportshop.com/?utm_source=Bleacher%20Report&amp;utm_medium=referral&amp;utm_campaign=Bleacher%20Report%20Website%20Menu">B/R Shop</a></li><li class="atom nav-link parent-link top-level" id="more"><a>More</a></li></ol></nav><nav id="non-league-links"><ol class="molecule nav-list"><li class="atom nav-link parent-link top-level" id="shows"><a>Shows</a></li><li class="atom nav-link top-level" id="kicks"><a href="/kicks">B/R Kicks</a></li><li class="atom nav-link top-level" id="https://live.bleacherreport.com?utm_source=Website&amp;utm_medium=BleacherReport&amp;utm_campaign=brws-General-topnav"><a href="https://live.bleacherreport.com?utm_source=Website&amp;utm_medium=BleacherReport&amp;utm_campaign=brws-General-topnav">B/R Live</a></li><li class="atom nav-link top-level" id="https://bleacherreport.com/br-mag"><a href="https://bleacherreport.com/br-mag">Mag</a></li><li class="atom nav-link top-level" id="mobile"><a href="/mobile">Get the App</a></li><li class="atom nav-link top-level" id="https://bleacherreportshop.com/?utm_source=Bleacher%20Report&amp;utm_medium=referral&amp;utm_campaign=Bleacher%20Report%20Website%20Menu"><a href="https://bleacherreportshop.com/?utm_source=Bleacher%20Report&amp;utm_medium=referral&amp;utm_campaign=Bleacher%20Report%20Website%20Menu">B/R Shop</a></li></ol></nav><div class="tools-container"><ul class="userTools molecule"><li class="molecule userMenu"><img src="https://static-assets.bleacherreport.net/img/molecules/nav/flagUSGray.png" alt="content has been localized for visitors from the United States" class="flag"/>Account<div class="dropdown"><ul><li><a href="/sign_up" class="sign-up">Sign Up</a></li><li><a href="/sign_in" class="login">Login</a></li></ul><div class="dropdown-header">Edition</div><div class="atom dropdown-body"><ul class="edition-flags"><li><a class="selected" href="/us"><img src="https://static-assets.bleacherreport.net/img/molecules/nav/flagUS.png" alt="United States of America flag"/></a></li><li><a class="" href="/uk"><img src="https://static-assets.bleacherreport.net/img/molecules/nav/flagUK.png" alt="Great Britain flag"/></a></li></ul></div></div></li></ul></div></div></header><div class="atom score-card-carousel"><div class="react-multi-carousel-list  "><ul class="react-multi-carousel-track slider" style="transition:none;overflow:unset;transform:translate3d(0px,0,0)"></ul></div></div><div id="outer-container" class=""><div class="ad"><div class="br-ad-wrapper atom advert"><div id="br-ad-5" class="br-ad" data-collapsed="0" data-country="US" data-position="oop_skin_01" data-reload="1" data-responsive-size="[[[970,0],[[3,3]]],[[0,0],[]]]" data-size="[[3,3]]"></div></div></div><div class="ad"><div class="br-ad-wrapper atom advert"><div id="br-ad-1" class="br-ad" data-collapsed="0" data-country="US" data-position="bnr_atf_01" data-reload="2" data-responsive-size="[[[1280,0],[&quot;fluid&quot;,[1280,100],[970,250],[970,66],[728,90]]],[[970,0],[&quot;fluid&quot;,[970,250],[970,66],[728,90]]],[[728,0],[&quot;fluid&quot;,[728,90],[300,100],[320,50]]],[[0,0],[&quot;fluid&quot;,[300,100],[320,50]]]]" data-size="[[320,50],[320,1]]"></div></div></div><div id="main-content"><div id="ad-skin-measurability-l" class="ad-rail"></div><article class="page articlePage"><header><div class="atom share"><ul><li class="shareFacebook" title="Share this article on Facebook"><svg class="atom icon svg facebook" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 10 16"><title>Facebook Logo</title><path d="M6.24 16V8.7h2.45l.365-2.842H6.24V4.04c0-.822.227-1.384 1.41-1.384h1.5V.112C8.42.035 7.686-.002 6.953 0 4.79 0 3.3 1.325 3.3 3.76v2.098H.846V8.7H3.3V16h2.94z"></path></svg></li><li class="shareTwitter" title="Share this article on Twitter"><svg class="atom icon svg twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 14"><title>Twitter Logo</title><path d="M5.042 13.504c6.01 0 9.3-4.985 9.3-9.3 0-.14 0-.28-.006-.42.638-.46 1.192-1.04 1.632-1.697-.586.262-1.217.434-1.88.517.675-.402 1.192-1.046 1.44-1.81-.63.375-1.332.643-2.078.79C12.85.946 12.003.55 11.066.55c-1.804 0-3.27 1.467-3.27 3.27 0 .256.032.505.083.747-2.717-.134-5.126-1.44-6.74-3.417C.86 1.635.7 2.196.7 2.795c0 1.134.58 2.135 1.455 2.722-.536-.02-1.04-.166-1.48-.408v.043c0 1.58 1.13 2.907 2.62 3.207-.273.076-.56.115-.86.115-.21 0-.414-.02-.612-.058.414 1.3 1.626 2.244 3.053 2.27-1.12.88-2.53 1.402-4.06 1.402-.26 0-.523-.014-.778-.046 1.44.918 3.162 1.46 5.004 1.46"></path></svg></li><li class="shareLink" title="Copy this link to your clipboard"><svg class="atom icon svg link" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20 10"><title>Copy Link Icon</title><path d="M1.9 5c0-1.71 1.39-3.1 3.1-3.1h4V0H5C2.24 0 0 2.24 0 5s2.24 5 5 5h4V8.1H5C3.29 8.1 1.9 6.71 1.9 5zM6 6h8V4H6v2zm9-6h-4v1.9h4c1.71 0 3.1 1.39 3.1 3.1 0 1.71-1.39 3.1-3.1 3.1h-4V10h4c2.76 0 5-2.24 5-5s-2.24-5-5-5z"></path></svg></li></ul></div><button class="atom button" type="button"><a class="atom tagLink" href="/nfl"><div class="imgWrapper"><img src="https://cdn.bleacherreport.net/images/team_logos/328x328/nfl.png" alt="NFL logo"/></div><span class="teamAvatar__name">NFL</span></a></button><h1>Aaron Rodgers, Packers Defeat Drew Brees, Saints Despite Alvin Kamara&#x27;s 2 TDs</h1><span class="atom authorInfo"><a href="/users/1093730" rel="noopener noreferrer"><span class="name">Scott Polacek</span></a><a class="twitterHandle" rel="noopener noreferrer" target="_blank" href="http://twitter.com/@ScottPolacek"><span>@<!-- -->@ScottPolacek</span><svg class="atom icon svg twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 14"><title>Twitter Logo</title><path d="M5.042 13.504c6.01 0 9.3-4.985 9.3-9.3 0-.14 0-.28-.006-.42.638-.46 1.192-1.04 1.632-1.697-.586.262-1.217.434-1.88.517.675-.402 1.192-1.046 1.44-1.81-.63.375-1.332.643-2.078.79C12.85.946 12.003.55 11.066.55c-1.804 0-3.27 1.467-3.27 3.27 0 .256.032.505.083.747-2.717-.134-5.126-1.44-6.74-3.417C.86 1.635.7 2.196.7 2.795c0 1.134.58 2.135 1.455 2.722-.536-.02-1.04-.166-1.48-.408v.043c0 1.58 1.13 2.907 2.62 3.207-.273.076-.56.115-.86.115-.21 0-.414-.02-.612-.058.414 1.3 1.626 2.244 3.053 2.27-1.12.88-2.53 1.402-4.06 1.402-.26 0-.523-.014-.778-.046 1.44.918 3.162 1.46 5.004 1.46"></path></svg></a><span class="title">Featured Columnist</span></span><span class="date">September 28, 2020</span><button class="atom button commentCount" type="button"><span class="label"> <!-- -->Comments</span><svg class="atom icon svg commentBubble" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20 20"><title>Comment Bubble Icon</title><path d="M2 0h16c1.1 0 2 .9 2 2v18l-4-4H2c-1.1 0-2-.9-2-2V2C0 .9.9 0 2 0z"></path></svg></button></header><div class="organism contentStream"><div><div class="atom photo" itemscope="" itemType="http://schema.org/ImageObject"><p></p><div class="imgWrapper"><div class="atom placeholderImage"><img alt="Green Bay Packers quarterback Aaron Rodgers (12) passes under pressure from New Orleans Saints defensive end Carl Granderson (96) in the first half of an NFL football game in New Orleans, Sunday, Sept. 27, 2020. (AP Photo/Butch Dill)" src="https://static-assets.bleacherreport.net/img/atoms/placeholderImage/logo.png"/></div></div><small><span class="caption"></span><span itemProp="citation" class="credit">Butch Dill/Associated Press</span></small></div><p class=""><span>The Green Bay Packers continue to roll.</span></p><p class=""><span>Green Bay moved to 3-0 on the season with a 37-30 victory over the New Orleans Saints on Sunday at Mercedes-Benz Superdome. <a href="http://bleacherreport.com/aaron-rodgers">Aaron Rodgers</a> and Allen Lazard spearheaded the latest effort, helping their team keep pace with the undefeated Chicago Bears in the NFC North.</span></p><p class=""><span>As for the Saints, they are among the most disappointing teams in the early going at 1-2 despite a strong showing from Alvin Kamara while Michael Thomas was sidelined with injury.</span></p><div class="atom twitterEmbed"><div class="twitterEmbed__container"><blockquote class="twitter-tweet tw-align-center" data-lang="en">B/R Gridiron<!-- --> <span class="acct">@<!-- -->brgridiron</span><p lang="en" dir="ltr">Respect between Rodgers and Brees 🤝

(via @NFL)
https://t.co/3H5so7WChJ</p><a href="https://twitter.com/brgridiron/status/1310423742099587072"></a></blockquote></div></div><p class="">           </p><p class=""><strong>Notable Player Stats</strong></p><ul class="atom bulletedList"><li>Aaron Rodgers, QB, GB: 21-of-32 passing for 283 yards, 3 TDs, 0 INTs</li><li>Aaron Jones, RB, GB: 16 carries for 69 yards, 1 TD</li><li>Allen Lazard, WR, GB: 6 catches for 146 yards, 1 TD</li><li><a href="http://bleacherreport.com/drew-brees">Drew Brees</a>, QB, NO: 29-of-36 for 288 yards, 3 TD, 0 INT</li><li>Alvin Kamara, RB, NO: 6 carries for 58 yards; 13 catches for 139 yards, 2 TDs</li></ul><p class=""><strong>            </strong></p><p class=""><strong>Aaron Rodgers Wins QB Battle and Game</strong></p><div class="ad"><div class="lazy br-ad-wrapper atom advert"><div id="br-ad-6358156" class="br-ad-lazy" data-collapsed="0" data-country="US" data-position="rect_atf_01" data-reload="1" data-responsive-size="[[[970,0],[&quot;fluid&quot;,[970,250],[970,66],[728,90],[300,250]]],[[728,0],[&quot;fluid&quot;,[728,90],[300,250]]],[[0,0],[&quot;fluid&quot;,[300,250],[320,50]]]]" data-size="[[300,600],[300,250],[300,2]]"></div></div></div><p class=""><span>The clear headline going into Sunday's contest was the quarterback battle.</span></p><p class=""><span>After all, Rodgers and Brees are both headed to the Hall of Fame with a Lombardi Trophy and astounding passing numbers on their resumes. They have faced each other in the playoffs—and may do so again this season—and had an opportunity to pick up a key win in the early NFC race.</span></p><p class=""><span>Both were without their star wide receivers Sunday with Thomas and Davante Adams sidelined, which put more pressure on the signal-callers' shoulders.</span></p><div class="molecule nr-video-manager"><div><a rel="noopener noreferrer" target="_blank" class="molecule thumbnail"><img alt="" src="https://media.bleacherreport.com/image/upload/v1601259174/gmeztytghjrm4m6bxvax.jpg" sizes="
  (max-width: 1024px) 100vw,
  (max-width: 1440px) 60vw,
  1440px
" srcSet="https://media.bleacherreport.com/image/upload/v1601259174/gmeztytghjrm4m6bxvax.jpg 375w,https://media.bleacherreport.com/image/upload/v1601259174/gmeztytghjrm4m6bxvax.jpg 768w,https://media.bleacherreport.com/image/upload/v1601259174/gmeztytghjrm4m6bxvax.jpg"/><svg class="atom icon svg videoPlay" xmlns="http://www.w3.org/2000/svg" viewBox="1 0 59 60"><title>Video Play Button</title><path d="M30.5 0C13.932 0 .5 13.43.5 30s13.432 30 30 30c16.57 0 30-13.43 30-30S47.07 0 30.5 0zm0 54c-13.233 0-24-10.766-24-24s10.767-24 24-24c13.234 0 24 10.766 24 24s-10.766 24-24 24zm-7.274-32.4v16.8c0 2.31 1.637 3.255 3.638 2.1l14.549-8.4c2-1.155 2-3.045 0-4.2l-14.55-8.4c-2-1.155-3.637-.21-3.637 2.1z"></path></svg></a><div class="atom video-indicator"><span class="text">Videos you might like </span> </div></div></div><div class="atom twitterEmbed"><div class="twitterEmbed__container"><blockquote class="twitter-tweet tw-align-center" data-lang="en">B/R Gridiron<!-- --> <span class="acct">@<!-- -->brgridiron</span><p lang="en" dir="ltr">Rodgers back to Lazard for the easy 6 

(via @NFL)
https://t.co/rcTSkurtAL</p><a href="https://twitter.com/brgridiron/status/1310386978697826304"></a></blockquote></div></div><div class="atom twitterEmbed"><div class="twitterEmbed__container"><blockquote class="twitter-tweet tw-align-center" data-lang="en">Bleacher Report<!-- --> <span class="acct">@<!-- -->BleacherReport</span><p lang="en" dir="ltr">Rodgers no-look pass 😯

(via @thecheckdown)
https://t.co/T6QdOWVwdy</p><a href="https://twitter.com/BleacherReport/status/1310404863394627585"></a></blockquote></div></div><div class="atom twitterEmbed"><div class="twitterEmbed__container"><blockquote class="twitter-tweet tw-align-center" data-lang="en">Bleacher Report<!-- --> <span class="acct">@<!-- -->BleacherReport</span><p lang="en" dir="ltr">RODGERS BOMB TO LAZARD 😱

(via @NFL)
https://t.co/gZtPNzLxfG</p><a href="https://twitter.com/BleacherReport/status/1310386352525959169"></a></blockquote></div></div><p class=""><span>Rodgers answered that pressure with an immediate connection with Lazard, who he found for the visitors' first touchdown in the second quarter. Rodgers also hit Lazard for a 72-yard deep ball in the third quarter, which set up an Aaron Jones touchdown on 4th-and-goal.</span></p><p class=""><span>Brees worked underneath and kept pace with touchdown passes to Kamara and Emmanuel Sanders, but Rodgers lofted a perfectly placed pass to Marcedes Lewis late in the third quarter for another score. Lewis appeared to get away with a push-off, but that didn't take away from the touch No. 12 showed by fitting it in over the nearest defender.</span></p><div class="atom twitterEmbed"><div class="twitterEmbed__container"><blockquote class="twitter-tweet tw-align-center" data-lang="en">B/R Gridiron<!-- --> <span class="acct">@<!-- -->brgridiron</span><p lang="en" dir="ltr">Marcedes Lewis found a way for this grab 💪

(via @thecheckdown)
https://t.co/2kuPuzHVmn</p><a href="https://twitter.com/brgridiron/status/1310408327138926593"></a></blockquote></div></div><div class="atom twitterEmbed"><div class="twitterEmbed__container"><blockquote class="twitter-tweet tw-align-center" data-lang="en">Michael Thomas<!-- --> <span class="acct">@<!-- -->Cantguardmike</span><p lang="en" dir="ltr">Push off lol</p><a href="https://twitter.com/Cantguardmike/status/1310406399487336448"></a></blockquote></div></div><p class=""><span>Rodgers worked his magic one more time in the fourth quarter on a key 3rd-and-3 by drawing New Orleans offside with his patented hard count and throwing it to the end zone, where there was pass interference.</span></p><p class=""><span>He found Robert Tonyan for a touchdown from there, all but clinching the win for Green Bay.</span></p><p class="">              </p><p class=""><strong>Saints Waste Brilliant Performance from Alvin Kamara</strong></p><div class="ad"><div class="lazy br-ad-wrapper atom advert"><div id="br-ad-23308439" class="br-ad-lazy" data-collapsed="0" data-country="US" data-position="rect_atf_02" data-reload="1" data-responsive-size="[[[970,0],[&quot;fluid&quot;,[970,250],[970,66],[728,90],[300,250]]],[[728,0],[&quot;fluid&quot;,[728,90],[300,250]]],[[0,0],[&quot;fluid&quot;,[300,250],[320,50]]]]" data-size="[[300,600],[300,250],[300,2]]"></div></div></div><p class=""><span>No Thomas. Brees past his prime and struggling to throw downfield. Needing to keep up with Rodgers on the other end.</span></p><p class=""><span>There was plenty stacked against the Saints offense in Sunday's contest, but it had one thing going for it: Kamara. The electrifying running back put New Orleans on his back from the early going, flashing into space on underneath routes for Brees, picking up yardage between the tackles and leaving Green Bay grasping at his feet.</span></p><div class="atom twitterEmbed"><div class="twitterEmbed__container"><blockquote class="twitter-tweet tw-align-center" data-lang="en">Gregg Rosenthal<!-- --> <span class="acct">@<!-- -->greggrosenthal</span><p lang="en" dir="ltr">The Saints entire offense is built around Kamara breaking tackles</p><a href="https://twitter.com/greggrosenthal/status/1310416414734340096"></a></blockquote></div></div><div class="atom twitterEmbed"><div class="twitterEmbed__container"><blockquote class="twitter-tweet tw-align-center" data-lang="en">B/R Gridiron<!-- --> <span class="acct">@<!-- -->brgridiron</span><p lang="en" dir="ltr">Kamara just having fun with it 💨

(via @NFL)
https://t.co/XP7pl8p42U</p><a href="https://twitter.com/brgridiron/status/1310388308355108865"></a></blockquote></div></div><div class="atom twitterEmbed"><div class="twitterEmbed__container"><blockquote class="twitter-tweet tw-align-center" data-lang="tl">B/R Gridiron<!-- --> <span class="acct">@<!-- -->brgridiron</span><p lang="tl" dir="ltr">Alvin Kamara TOO STRONG 💪

(via @NFL)
https://t.co/43wr2su22v</p><a href="https://twitter.com/brgridiron/status/1310379624363249664"></a></blockquote></div></div><div class="atom twitterEmbed"><div class="twitterEmbed__container"><blockquote class="twitter-tweet tw-align-center" data-lang="en">B/R Gridiron<!-- --> <span class="acct">@<!-- -->brgridiron</span><p lang="en" dir="ltr">Packers defense trying to tackle Kamara https://t.co/quUUrQTIei</p><a href="https://twitter.com/brgridiron/status/1310410425486385153"></a></blockquote></div></div><p class=""><span>Never was he more impressive than in the third quarter when he took a Brees pass behind the line of scrimmage, froze a potential tackler, bounced off another and worked his way downfield by changing speeds and lowering his shoulder.</span></p><p class=""><span>The end result was a 52-yard score, which was his second of the game and will stand as one of the best touchdowns of the entire season.</span></p><div class="atom twitterEmbed"><div class="twitterEmbed__container"><blockquote class="twitter-tweet tw-align-center" data-lang="tl">Bleacher Report<!-- --> <span class="acct">@<!-- -->BleacherReport</span><p lang="tl" dir="ltr">KAMARA IS A PROBLEM 🔥

(via @Saints)
https://t.co/np6wSln05Z</p><a href="https://twitter.com/BleacherReport/status/1310409982194507776"></a></blockquote></div></div><div class="atom twitterEmbed"><div class="twitterEmbed__container"><blockquote class="twitter-tweet tw-align-center" data-lang="en">Next Gen Stats<!-- --> <span class="acct">@<!-- -->NextGenStats</span><p lang="en" dir="ltr">Alvin Kamara gained 57 yards after catch on this 52-yard touchdown, +40 over expected according to our Expected YAC model.

Kamara never reached a speed faster than 15.28 MPH on the play, while Erik McCoy (#78) reached 16.22 MPH as a lead blocker.

#GBvsNO | #Saints https://t.co/wxKFfzUhNK</p><a href="https://twitter.com/NextGenStats/status/1310411484292243457"></a></blockquote></div></div><p class=""><span>That touchdown, along with a key 4th-down stop by Malcolm Jenkins, gave the Saints all the momentum until head coach Sean Payton decided to put Taysom Hill at quarterback and run an option play instead of just running with Kamara. The result was a fumble, which Green Bay parlayed into a field goal and a fourth-quarter lead.</span></p><p class=""><span>It is not difficult to envision the Saints electing to give the ball to Kamara again instead of disrupting their momentum with Hill and scoring to take the lead for good in that situation.</span></p><p class=""><span>Instead, his incredible performance went to waste.</span></p><p class=""><span>         </span></p><p class=""><strong>What's Next?</strong></p><p class=""><span>Both teams remain in the NFC in Week 4 when the Packers host the Atlanta Falcons and the Saints are at the Detroit Lions.</span></p></div></div><div class="footer-wrapper"><footer><div class="atom share"><ul><li class="shareFacebook" title="Share this article on Facebook"><svg class="atom icon svg facebook" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 10 16"><title>Facebook Logo</title><path d="M6.24 16V8.7h2.45l.365-2.842H6.24V4.04c0-.822.227-1.384 1.41-1.384h1.5V.112C8.42.035 7.686-.002 6.953 0 4.79 0 3.3 1.325 3.3 3.76v2.098H.846V8.7H3.3V16h2.94z"></path></svg></li><li class="shareTwitter" title="Share this article on Twitter"><svg class="atom icon svg twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 14"><title>Twitter Logo</title><path d="M5.042 13.504c6.01 0 9.3-4.985 9.3-9.3 0-.14 0-.28-.006-.42.638-.46 1.192-1.04 1.632-1.697-.586.262-1.217.434-1.88.517.675-.402 1.192-1.046 1.44-1.81-.63.375-1.332.643-2.078.79C12.85.946 12.003.55 11.066.55c-1.804 0-3.27 1.467-3.27 3.27 0 .256.032.505.083.747-2.717-.134-5.126-1.44-6.74-3.417C.86 1.635.7 2.196.7 2.795c0 1.134.58 2.135 1.455 2.722-.536-.02-1.04-.166-1.48-.408v.043c0 1.58 1.13 2.907 2.62 3.207-.273.076-.56.115-.86.115-.21 0-.414-.02-.612-.058.414 1.3 1.626 2.244 3.053 2.27-1.12.88-2.53 1.402-4.06 1.402-.26 0-.523-.014-.778-.046 1.44.918 3.162 1.46 5.004 1.46"></path></svg></li><li class="shareLink" title="Copy this link to your clipboard"><svg class="atom icon svg link" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20 10"><title>Copy Link Icon</title><path d="M1.9 5c0-1.71 1.39-3.1 3.1-3.1h4V0H5C2.24 0 0 2.24 0 5s2.24 5 5 5h4V8.1H5C3.29 8.1 1.9 6.71 1.9 5zM6 6h8V4H6v2zm9-6h-4v1.9h4c1.71 0 3.1 1.39 3.1 3.1 0 1.71-1.39 3.1-3.1 3.1h-4V10h4c2.76 0 5-2.24 5-5s-2.24-5-5-5z"></path></svg></li></ul></div><div></div></footer><div class="atom relatedContent offscreen"></div><div class="atom outbrain OUTBRAIN" data-src="https://bleacherreport.com/articles/2910904" data-widget-id="AR_8" data-ob-template="BleacherReport_1"></div></div></article><div id="ad-skin-measurability-r" class="ad-rail"></div></div><div class="adsContainer"></div><footer class="molecule footer"><div><svg class="atom logo svg brPlateLight" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 1600 1200"><title>Bleacher Report Logo</title><g><rect width="1600" height="1200" fill="#fff"></rect><path fill="#000" d="M484.85 200H200v800h284.85L600 884.85v-229.7L544.85 600 600 544.85v-229.7zM320 540V320h115.15L480 364.85v130.3L435.15 540zm115.15 120L480 704.85v130.3L435.15 880H320V660zM1415 1000l-99.35-370.79 84.35-84.36v-229.7L1284.85 200H1000v800h120V660h83.9l91.1 340zm-295-680h115.15l44.85 44.85v130.3L1235.15 540H1120zM700 770.71l200-200V429.29l-200 200v141.42z"></path></g></svg><ul class="social"><li><a href="https://facebook.com/bleacherreport/"><svg class="atom icon svg facebookFilled" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 267 267"><title>Facebook Logo</title><path d="M252.16,0H14.73A14.73,14.73,0,0,0,0,14.73V252.16a14.73,14.73,0,0,0,14.73,14.73H142.56V163.54H107.78V123.26h34.78V93.55c0-34.47,21.05-53.24,51.81-53.24a285.37,285.37,0,0,1,31.08,1.59v36H204.12c-16.72,0-20,7.95-20,19.61v25.72H224l-5.19,40.28H184.15V266.89h68a14.73,14.73,0,0,0,14.73-14.73V14.73A14.73,14.73,0,0,0,252.16,0Z"></path></svg></a></li><li><a href="https://twitter.com/bleacherreport/"><svg class="atom icon svg twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 14"><title>Twitter Logo</title><path d="M5.042 13.504c6.01 0 9.3-4.985 9.3-9.3 0-.14 0-.28-.006-.42.638-.46 1.192-1.04 1.632-1.697-.586.262-1.217.434-1.88.517.675-.402 1.192-1.046 1.44-1.81-.63.375-1.332.643-2.078.79C12.85.946 12.003.55 11.066.55c-1.804 0-3.27 1.467-3.27 3.27 0 .256.032.505.083.747-2.717-.134-5.126-1.44-6.74-3.417C.86 1.635.7 2.196.7 2.795c0 1.134.58 2.135 1.455 2.722-.536-.02-1.04-.166-1.48-.408v.043c0 1.58 1.13 2.907 2.62 3.207-.273.076-.56.115-.86.115-.21 0-.414-.02-.612-.058.414 1.3 1.626 2.244 3.053 2.27-1.12.88-2.53 1.402-4.06 1.402-.26 0-.523-.014-.778-.046 1.44.918 3.162 1.46 5.004 1.46"></path></svg></a></li><li><a href="https://instagram.com/bleacherreport/"><svg class="atom icon svg instagram" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><title>Instagram Logo</title><g><path d="M11.816 5.744c-3.353 0-6.072 2.72-6.072 6.072 0 3.353 2.72 6.072 6.072 6.072 3.353 0 6.072-2.72 6.072-6.072 0-1.61-.64-3.155-1.778-4.294-1.14-1.138-2.684-1.778-4.294-1.778zm0 10.016c-2.178 0-3.944-1.766-3.944-3.944s1.766-3.944 3.944-3.944 3.944 1.766 3.944 3.944-1.766 3.944-3.944 3.944z"></path><circle cx="18.128" cy="5.52" r="1.416"></circle><path d="M23.024 4.08c-.614-1.587-1.87-2.842-3.456-3.456-.92-.345-1.89-.532-2.872-.552C15.432.016 15.032 0 11.824 0S8.208 0 6.952.072C5.97.092 5 .28 4.08.624 2.493 1.238 1.238 2.494.624 4.08.28 5 .092 5.97.072 6.952.016 8.216 0 8.616 0 11.824s0 3.616.072 4.872c.02.982.207 1.953.552 2.872.614 1.587 1.87 2.842 3.456 3.456.917.36 1.888.56 2.872.592 1.264.056 1.664.072 4.872.072s3.616 0 4.872-.072c.982-.02 1.953-.207 2.872-.552 1.587-.614 2.842-1.87 3.456-3.456.345-.92.532-1.89.552-2.872.056-1.264.072-1.664.072-4.872s0-3.616-.072-4.872c-.016-.995-.202-1.98-.552-2.912zm-1.6 12.52c-.007.757-.145 1.506-.408 2.216-.398 1.033-1.215 1.85-2.248 2.248-.702.26-1.443.398-2.192.408-1.248.056-1.6.072-4.8.072-3.2 0-3.528 0-4.8-.072-.75-.01-1.49-.148-2.192-.408-1.037-.395-1.857-1.213-2.256-2.248-.26-.702-.398-1.443-.408-2.192-.056-1.248-.072-1.6-.072-4.8 0-3.2 0-3.528.072-4.8.007-.757.145-1.506.408-2.216.4-1.035 1.22-1.853 2.256-2.248.702-.26 1.443-.398 2.192-.408 1.248-.056 1.6-.072 4.8-.072 3.2 0 3.528 0 4.8.072.75.01 1.49.148 2.192.408 1.033.398 1.85 1.215 2.248 2.248.26.702.398 1.443.408 2.192.056 1.248.072 1.6.072 4.8 0 3.2 0 3.544-.056 4.8h-.016z"></path></g></svg></a></li></ul><ul class="links"><li><a href="/pages/about">About</a></li><li><a href="/pages/advertise">Advertise</a></li><li><a href="/pages/contact">Contact Us</a></li><li><a href="https://careers.bleacherreport.com/">Careers</a></li><li><a href="/pages/comguidelines">Community Guidelines</a></li><li><a href="/pages/privacy">Privacy</a></li><li><a href="#">Do Not Sell My Personal Information</a></li><li><a href="/pages/terms">Terms Of Use</a></li><li><a href="https://www.stubhub.com/?gcid=chAFF-_-geoUS-_-genAllTix-_-dt170312-_-cmpBR_footr-_-partBleacherReport">Tickets</a></li><li><a href="#">AdChoices <img src="https://static-assets.bleacherreport.net/img/molecules/footer/adChoices.png" width="12" height="12" alt="" role="presentation" style="vertical-align:middle"/></a></li></ul></div><small class="copyright">
  Copyright © 2020 Bleacher Report, Inc. Turner Broadcasting System, Inc.
  All Rights Reserved.
  BleacherReport.com is part of Bleacher Report – Turner Sports Network, part of the Turner Sports and Entertainment Network.
<!-- -->
  Certain photos copyright © 2020 Getty Images.
  Any commercial use or distribution without the express written consent of Getty Images is strictly prohibited.
<a href="#">AdChoices <img src="https://static-assets.bleacherreport.net/img/molecules/footer/adChoices.png" width="12" height="12" alt="" role="presentation" style="vertical-align:middle"/></a></small><svg class="atom logo svg turner" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 601.7 105.2"><title>Turner Logo</title><path d="M502.3 63.5c1.7-7.2 2.7-13.3 2.7-19.3C505 19.6 488.5.1 460.5.1 430 .1 405.7 22.9 401 52.6c-5 31.5 14.3 52.5 44.2 52.5 23.6 0 43.5-13.3 53.7-33.5h-36.1c-4.5 4.7-10.5 6-15.7 5.9-10.4-.2-15.3-6.3-15.4-14h70.6zm-43.7-36.9c9.2 0 15.4 5.8 15.1 14.5h-37c3.5-8.5 11.8-14.5 21.9-14.5zM579 .6c-12.5 0-22.8 10.2-22.8 22.6 0 12.6 10.3 22.9 22.8 22.9 12.6 0 22.9-10.3 22.7-22.9C601.9 10.7 591.6.6 579 .6zM364.9 0c-11.4 0-25.3 6.9-32 16l3.8-13.4h-32.4l-17.7 100.2h34.8l10-56.7c1.7-9.4 9-15.9 17.7-15.9 8.4 0 12.4 6.9 10.9 15.9l-10 56.7h34.8l10.9-61.5C400.1 16 387.8 0 364.9 0zM5.7 2.6h91.6l-5.7 32.2H63.8l-12 67.9H17l12-67.9H0M105.3 2.6h34.8l-9.8 55.7c-1.7 9.6 2.7 15.3 11.2 15.3 8.7 0 15.5-6 17.2-15.3l9.8-55.7h34.8L193.9 56c-6 33.4-27.7 49-56.9 49-29.8 0-46.9-16.3-41.1-49.2l9.4-53.2zM194.6 102.7h34.7L247 2.6h-34.8M270.2.6c-12.4 0-22.8 10.2-22.8 22.6 0 12.6 10.3 22.9 22.8 22.9 12.6 0 22.9-10.3 22.8-22.9.1-12.5-10.2-22.6-22.8-22.6zM503.3 102.7H538L555.7 2.6h-34.8"></path></svg></footer></div></div></div><script id="__LOADABLE_REQUIRED_CHUNKS__" type="application/json">[]</script><script async="" data-chunk="bundle" src="https://static-assets.bleacherreport.net/js/vendor-1c140878.js"></script><script async="" data-chunk="bundle" src="https://static-assets.bleacherreport.net/js/bundle.5a0f1c3e4cecca98cf34dd6d5a7b2f8a.js"></script><div id="pixels"></div><div id="infogram-async"></div><div><!-- Generated on 09/28/20 at 05:19 AM --></div></body></html>