<!DOCTYPE html><html class="no-js" lang="en"><head><meta charSet="utf-8"/><meta http-equiv="Accept-CH" content="DPR,Width,Viewport-Width"/><meta name="aol-te-auth" content="1c424580-0f86-4d9b-88b2-bc8c0d029d4c"/><meta name="blitz" content="mu-6e4ce5cd-57f20d11-7c0ecee9-d55c79e2"/><meta name="msvalidate.01" content="7A63840181953B2A5A1FEA25FB45A991"/><meta name="robots" content="NOODP,NOYDIR"/><meta name="verify-v1" content="+Ntj422Jc4V03qgBqLYbF3LMvrursV0X2btn2Zoqn9w="/><meta name="description" content="LiAngelo Ball  declared for the 2018  NBA  draft Tuesday, according to Ball&#x27;s agent, Harrison Gaines, per  Shams Charania     of Yahoo Sports.     Charania noted Ball has already submitted early-entry paperwork with the NBA..."/><meta name="keywords" content="Basketball, NBA, NBA Draft, Breaking News, LiAngelo Ball"/><meta name="viewport" content="width=device-width, initial-scale=1"/><meta property="fb:app_id" content="135174055162"/><meta name="al:iphone:url" content="teamstream://article/bleacherreport.com/articles/2766836-report-liangelo-ball-declares-for-2018-nba-draft-played-with-lamelo-overseas"/><meta name="al:iphone:app_store_id" content="418075935"/><meta name="al:iphone:app_name" content="Bleacher Report"/><meta name="al:ipad:url" content="teamstream://article/bleacherreport.com/articles/2766836-report-liangelo-ball-declares-for-2018-nba-draft-played-with-lamelo-overseas"/><meta name="al:ipad:app_store_id" content="484725748"/><meta name="al:ipad:app_name" content="Bleacher Report"/><meta name="al:android:url" content="http://bleacherreport.com/articles/2766836-report-liangelo-ball-declares-for-2018-nba-draft-played-with-lamelo-overseas"/><meta name="al:android:app_name" content="Bleacher Report"/><meta name="al:android:package" content="com.bleacherreport.android.teamstream"/><meta name="al:web:url" content="http://bleacherreport.com/articles/2766836-report-liangelo-ball-declares-for-2018-nba-draft-played-with-lamelo-overseas"/><meta property="og:site_name" content="Bleacher Report"/><meta property="og:locale" content="en_US"/><meta name="p:domain_verify" content="0c768466449ebb550411234d6d4ffc30"/><meta name="theme-color" content="#000"/><meta name="twitter:app:name:iphone" content="Bleacher Report"/><meta name="twitter:app:id:iphone" content="418075935"/><meta name="twitter:app:name:ipad" content="Bleacher Report"/><meta name="twitter:app:id:ipad" content="484725748"/><meta name="twitter:app:name:googleplay" content="Bleacher Report"/><meta name="twitter:app:id:googleplay" content="com.bleacherreport.android.teamstream"/><meta name="twitter:widgets:new-embed-design" content="on"/><meta name="twitter:site" content="@bleacherreport"/><meta name="article:publisher" content="https://www.facebook.com/bleacherreport"/><meta name="author" content="Mike  Chiari"/><meta property="og:description" content="LiAngelo Ball  declared for the 2018  NBA  draft Tuesday, according to Ball&#x27;s agent, Harrison Gaines, per  Shams Charania     of Yahoo Sports.     Charania noted Ball has already submitted early-entry paperwork with the NBA..."/><meta property="og:image" content="https://img.bleacherreport.net/img/images/photos/003/732/006/hi-res-2b08517000d1647d8121cb57c5a92a5a_crop_exact.jpg?w=1200&amp;h=1200&amp;q=75"/><meta property="og:title" content="Report: LiAngelo Ball Declares for 2018 NBA Draft; Played with LaMelo Overseas"/><meta property="og:type" content="article"/><meta property="og:url" content="http://bleacherreport.com/articles/2766836-report-liangelo-ball-declares-for-2018-nba-draft-played-with-lamelo-overseas"/><meta name="pubdate" content="2018-03-27T09:42:58-04:00"/><meta name="thumbnail" content="https://img.bleacherreport.net/img/images/photos/003/732/006/hi-res-2b08517000d1647d8121cb57c5a92a5a_crop_exact.jpg?w=1200&amp;h=1200&amp;q=75"/><meta name="twitter:app:url:googleplay" content="http://bleacherreport.com/articles/2766836-report-liangelo-ball-declares-for-2018-nba-draft-played-with-lamelo-overseas"/><meta name="twitter:app:url:ipad" content="teamstream://article/bleacherreport.com/articles/2766836-report-liangelo-ball-declares-for-2018-nba-draft-played-with-lamelo-overseas"/><meta name="twitter:app:url:iphone" content="teamstream://article/bleacherreport.com/articles/2766836-report-liangelo-ball-declares-for-2018-nba-draft-played-with-lamelo-overseas"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:description" content="LiAngelo Ball  declared for the 2018  NBA  draft Tuesday, according to Ball&#x27;s agent, Harrison Gaines, per  Shams Charania     of Yahoo Sports.     Charania noted Ball has already submitted early-entry paperwork with the NBA..."/><meta name="twitter:image" content="https://img.bleacherreport.net/img/images/photos/003/732/006/hi-res-2b08517000d1647d8121cb57c5a92a5a_crop_exact.jpg?w=1200&amp;h=1200&amp;q=75"/><meta name="twitter:title" content="Report: LiAngelo Ball Declares for 2018 NBA Draft; Played with LaMelo Overseas"/><meta name="twitter:url" content="http://bleacherreport.com/articles/2766836-report-liangelo-ball-declares-for-2018-nba-draft-played-with-lamelo-overseas"/><link rel="shortcut icon" href="https://static-assets.bleacherreport.com/favicon.ico"/><title>Report: LiAngelo Ball Declares for 2018 NBA Draft; Played with LaMelo Overseas | Bleacher Report | Latest News, Videos and Highlights</title><script type="text/javascript">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</script><link rel="stylesheet" type="text/css" href="https://static-assets.bleacherreport.com/css/global.9f9e7aae6ebc9a6a3eab92d009cb6196.css" crossOrigin="anonymous"/><link rel="stylesheet" type="text/css" href="https://static-assets.bleacherreport.com/css/atomic.db6fa4621cb322243f0cd771d877238e.css" crossOrigin="anonymous"/><script type="text/javascript"><!-- 

	var _sf_startpt = (new Date()).getTime()
	var _sf_async_config =  _sf_async_config || {};
	_sf_async_config.domain = "bleacherreport.com";
	_sf_async_config.uid = 45648;
	_sf_async_config.path = "/";
	var _cbm = _cbm || [];
	_cbm.push(["readyForTesting", true]);
 
 --></script><script type="application/ld+json">{"@context":"http://schema.org","@type":"NewsArticle","keywords":"Basketball,NBA,NBA_Draft,Breaking_News,LiAngelo_Ball","isFamilyFriendly":true,"inLanguage":"English","mainEntityOfPage":"LiAngelo Ball  declared for the 2018  NBA  draft Tuesday, according to Ball's agent, Harrison Gaines, per  Shams Charania     of Yahoo Sports.     Charania noted Ball has already submitted early-entry paperwork with the NBA...","headline":"Report: LiAngelo Ball Declares for 2018 NBA Draft; Played with LaMelo Overseas","thumbnailURL":"https://img.bleacherreport.net/img/images/photos/003/732/006/hi-res-2b08517000d1647d8121cb57c5a92a5a_crop_exact.jpg?w=900&h=600&q=75","image":{"type":"ImageObject","url":"https://img.bleacherreport.net/img/images/photos/003/732/006/hi-res-2b08517000d1647d8121cb57c5a92a5a_crop_exact.jpg?w=900&h=600&q=75"},"datePublished":"2018-03-27T09:42:58-04:00","dateModified":"2018-03-27T10:06:02-04:00","author":{"@type":"Person","name":"Mike  Chiari","jobTitle":"Featured Columnist"},"publisher":{"@type":"Organization","name":"Bleacher Report","url":"http://bleacherreport.com","logo":{"type":"ImageObject","url":"https://static-assets.bleacherreport.com/img/br_60_height.png","width":"80","height":"60"}},"description":"LiAngelo Ball  declared for the 2018  NBA  draft Tuesday, according to Ball's agent, Harrison Gaines, per  Shams Charania     of Yahoo Sports.     Charania noted Ball has already submitted early-entry paperwork with the NBA...","about":"LiAngelo Ball  declared for the 2018  NBA  draft Tuesday, according to Ball's agent, Harrison Gaines, per  Shams Charania     of Yahoo Sports.     Charania noted Ball has already submitted early-entry paperwork with the NBA..."}</script><link rel="manifest" type="" href="/manifest.json" crossOrigin="anonymous"/><link rel="mask-icon" type="" href="/img/favicon/safariMaskIcon.svg" color="#000000" crossOrigin="anonymous"/><link rel="apple-touch-icon" type="" href="/img/favicon/appleTouchIcon.png" sizes="180x180" crossOrigin="anonymous"/><link rel="icon" type="" href="/img/favicon/favicon32.png" sizes="32x32" crossOrigin="anonymous"/><link rel="icon" type="" href="/img/favicon/favicon16.png" sizes="16x16" crossOrigin="anonymous"/><link rel="amphtml" type="" href="https://syndication.bleacherreport.com/amp/2766836-report-liangelo-ball-declares-for-2018-nba-draft-played-with-lamelo-overseas.amp.html" crossOrigin="anonymous"/><link rel="alternate" type="" href="android-app://com.bleacherreport.android.teamstream/http/bleacherreport.com/articles/2766836-report-liangelo-ball-declares-for-2018-nba-draft-played-with-lamelo-overseas" crossOrigin="anonymous"/><link rel="alternate" type="" href="android-app://com.bleacherreport.android.teamstream/teamstream/article/bleacherreport.com/articles/2766836-report-liangelo-ball-declares-for-2018-nba-draft-played-with-lamelo-overseas" crossOrigin="anonymous"/><link rel="alternate" type="" href="ios-app://418075935/http/bleacherreport.com/articles/2766836-report-liangelo-ball-declares-for-2018-nba-draft-played-with-lamelo-overseas" crossOrigin="anonymous"/><link rel="canonical" type="" href="http://bleacherreport.com/articles/2766836-report-liangelo-ball-declares-for-2018-nba-draft-played-with-lamelo-overseas" crossOrigin="anonymous"/><link rel="alternate" type="application/json+oembed" href="https://bleacherreport.com/oembed?url=http%3A%2F%2Fbleacherreport.com%2Farticles%2F2766836-report-liangelo-ball-declares-for-2018-nba-draft-played-with-lamelo-overseas" crossOrigin="anonymous"/><link rel="alternate" type="application/xml+oembed" href="https://bleacherreport.com/oembed?url=http%3A%2F%2Fbleacherreport.com%2Farticles%2F2766836-report-liangelo-ball-declares-for-2018-nba-draft-played-with-lamelo-overseas&amp;format=xml" crossOrigin="anonymous"/></head><body><div id="app"><div class="template website light" data-reactroot=""><div class="analyticsContainer"><noscript> </noscript><noscript> <img src="https://sb.scorecardresearch.com/p?c1=2&amp;c2=6246855&amp;c4=bleacherreport.com%2F2766836&amp;cv=2&amp;cj=1" width="0" height="0" alt=""/></noscript><noscript> <img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1858549151057910&amp;ev=PageView&amp;noscript=1"/><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=215779442505424&amp;ev=PageView&amp;noscript=1"/></noscript></div><div class="fixedRegion"></div><header><div class="nav organism"><a id="br-logo" class="siteLogo" href="/"><svg class="atom svg logo br" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 1600 1200"><title>Bleacher Report Logo</title><g><path d="M484.85 200H200v800h284.85L600 884.85v-229.7L544.85 600 600 544.85v-229.7zM320 540V320h115.15L480 364.85v130.3L435.15 540zm115.15 120L480 704.85v130.3L435.15 880H320V660zM1415 1000l-99.35-370.79 84.35-84.36v-229.7L1284.85 200H1000v800h120V660h83.9l91.1 340zm-295-680h115.15l44.85 44.85v130.3L1235.15 540H1120zM700 770.71l200-200V429.29l-200 200v141.42z"></path></g></svg></a><nav id="league-links"><ol class="molecule nav-list"><li class="atom nav-link parent-link top-level" id="nba"><a href="/nba">NBA</a></li><li class="atom nav-link parent-link top-level" id="nfl"><a href="/nfl">NFL</a></li><li class="atom nav-link parent-link top-level" id="world-football"><a href="/world-football">World Football</a></li><li class="atom nav-link parent-link top-level" id="mlb"><a href="/mlb">MLB</a></li><li class="atom nav-link parent-link top-level" id="nhl"><a href="/nhl">NHL</a></li><li class="atom nav-link parent-link top-level" id="college-football"><a href="/college-football">CFB</a></li><li class="atom nav-link parent-link top-level" id="college-basketball"><a href="/college-basketball">CBB</a></li><li class="atom nav-link parent-link top-level" id="mma"><a href="/mma">MMA</a></li><li class="atom nav-link top-level" id="wwe"><a href="/wwe">WWE</a></li><li class="atom nav-link top-level" id="tennis"><a href="/tennis">Tennis</a></li><li class="atom nav-link top-level" id="golf"><a href="/golf">Golf</a></li><li class="atom nav-link top-level" id="nascar"><a href="/nascar">NASCAR</a></li><li class="atom nav-link top-level" id="boxing"><a href="/boxing">Boxing</a></li><li class="atom nav-link parent-link top-level" id="more"><a>More</a></li></ol></nav><nav id="non-league-links"><ol class="molecule nav-list"><li class="atom nav-link top-level" id="https://gameofzones.bleacherreport.com"><a href="https://gameofzones.bleacherreport.com">Game of Zones</a></li><li class="atom nav-link top-level" id="http://420.bleacherreport.com"><a href="http://420.bleacherreport.com">BRx420</a></li><li class="atom nav-link top-level" id="trending"><a href="/trending">Trending</a></li><li class="atom nav-link top-level" id="http://mag.bleacherreport.com/"><a href="http://mag.bleacherreport.com/">Mag</a></li><li class="atom nav-link top-level" id="https://www.stubhub.com/?gcid=chAFF-_-geoUS-_-genAllTix-_-dt170312-_-cmpBR_Main_Nav-_-partBleacherReport"><a href="https://www.stubhub.com/?gcid=chAFF-_-geoUS-_-genAllTix-_-dt170312-_-cmpBR_Main_Nav-_-partBleacherReport">Tickets</a></li><li class="atom nav-link top-level" id="mobile"><a href="/mobile">Get The App</a></li></ol></nav><div class="tools-container"><ul class="userTools molecule"><li><a href="/sign_up" class="sign-up">Sign Up</a></li><li><a href="/sign_in" class="login">Login</a></li></ul></div></div></header><div id="outer-container"><div class="ad"><div class="br-ad-wrapper atom advert"><div id="br-ad-5" class="br-ad" data-collapsed="1" data-position="oop_skin_01" data-reload="1" data-responsive-size="[[[970,0],[[3,3]]],[[0,0],[]]]" data-size="[[3,3]]"></div></div></div><div class="ad"><div class="br-ad-wrapper atom advert"><div id="br-ad-1" class="br-ad" data-collapsed="1" data-position="bnr_atf_01" data-reload="2" data-responsive-size="[[[1280,0],[[1280,100]]],[[970,0],[[970,250],[970,66]]],[[728,0],[[728,90]]],[[0,0],[[300,100],[320,50]]]]" data-size="[[320,50],[320,1]]"></div></div></div><div id="main-content"><article class="page articlePage"><header><div class="atom share"><ul><li class="shareFacebook" title="Share this article on Facebook"><svg class="atom svg icon facebook" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 10 16"><title>Facebook Logo</title><path d="M6.24 16V8.7h2.45l.365-2.842H6.24V4.04c0-.822.227-1.384 1.41-1.384h1.5V.112C8.42.035 7.686-.002 6.953 0 4.79 0 3.3 1.325 3.3 3.76v2.098H.846V8.7H3.3V16h2.94z"></path></svg></li><li class="shareTwitter" title="Share this article on Twitter"><svg class="atom svg icon twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 14"><title>Twitter Logo</title><path d="M5.042 13.504c6.01 0 9.3-4.985 9.3-9.3 0-.14 0-.28-.006-.42.638-.46 1.192-1.04 1.632-1.697-.586.262-1.217.434-1.88.517.675-.402 1.192-1.046 1.44-1.81-.63.375-1.332.643-2.078.79C12.85.946 12.003.55 11.066.55c-1.804 0-3.27 1.467-3.27 3.27 0 .256.032.505.083.747-2.717-.134-5.126-1.44-6.74-3.417C.86 1.635.7 2.196.7 2.795c0 1.134.58 2.135 1.455 2.722-.536-.02-1.04-.166-1.48-.408v.043c0 1.58 1.13 2.907 2.62 3.207-.273.076-.56.115-.86.115-.21 0-.414-.02-.612-.058.414 1.3 1.626 2.244 3.053 2.27-1.12.88-2.53 1.402-4.06 1.402-.26 0-.523-.014-.778-.046 1.44.918 3.162 1.46 5.004 1.46"></path></svg></li><li class="shareLink" title="Copy this link to your clipboard"><svg class="atom svg icon link" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20 10"><title>Copy Link Icon</title><path d="M1.9 5c0-1.71 1.39-3.1 3.1-3.1h4V0H5C2.24 0 0 2.24 0 5s2.24 5 5 5h4V8.1H5C3.29 8.1 1.9 6.71 1.9 5zM6 6h8V4H6v2zm9-6h-4v1.9h4c1.71 0 3.1 1.39 3.1 3.1 0 1.71-1.39 3.1-3.1 3.1h-4V10h4c2.76 0 5-2.24 5-5s-2.24-5-5-5z"></path></svg></li></ul></div><button type="button" class="atom button"><a class="atom teamAvatar" href="/nba-draft"><div class="imgWrapper"><img src="https://cdn.bleacherreport.net/images/team_logos/328x328/nba_draft.png" alt="NBA Draft logo"/></div><span>NBA Draft</span></a></button><h1>Report: LiAngelo Ball Declares for 2018 NBA Draft; Played with LaMelo Overseas</h1><span class="atom authorInfo"><a class="authorPhoto" href="/users/499306"><svg class="atom svg icon defaultUser" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 100 100"><circle cx="50" cy="50" r="50"></circle><g fill="#FFF" transform="translate(20 15)"><path d="M0 60.617C7.165 69.407 17.945 75 30 75s22.835-5.593 30-14.383C54.197 51.31 42.938 45 30 45 17.062 45 5.803 51.31 0 60.617z"></path><circle cx="30" cy="20" r="20"></circle></g></svg></a><a href="/users/499306" rel="noopener noreferrer"><span class="name">Mike  Chiari</span></a><a class="twitterHandle" rel="noopener noreferrer" target="_blank" href="https://twitter.com/mikechiari"><span>@<!-- -->mikechiari</span><svg class="atom svg icon twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 14"><title>Twitter Logo</title><path d="M5.042 13.504c6.01 0 9.3-4.985 9.3-9.3 0-.14 0-.28-.006-.42.638-.46 1.192-1.04 1.632-1.697-.586.262-1.217.434-1.88.517.675-.402 1.192-1.046 1.44-1.81-.63.375-1.332.643-2.078.79C12.85.946 12.003.55 11.066.55c-1.804 0-3.27 1.467-3.27 3.27 0 .256.032.505.083.747-2.717-.134-5.126-1.44-6.74-3.417C.86 1.635.7 2.196.7 2.795c0 1.134.58 2.135 1.455 2.722-.536-.02-1.04-.166-1.48-.408v.043c0 1.58 1.13 2.907 2.62 3.207-.273.076-.56.115-.86.115-.21 0-.414-.02-.612-.058.414 1.3 1.626 2.244 3.053 2.27-1.12.88-2.53 1.402-4.06 1.402-.26 0-.523-.014-.778-.046 1.44.918 3.162 1.46 5.004 1.46"></path></svg></a><span class="title">Featured Columnist</span></span><span class="date">March 27, 2018</span><button type="button" class="atom button commentCount"><span class="label"> <!-- -->Comments</span><svg class="atom svg icon commentBubble" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20 20"><title>Comment Bubble Icon</title><path d="M2 0h16c1.1 0 2 .9 2 2v18l-4-4H2c-1.1 0-2-.9-2-2V2C0 .9.9 0 2 0z"></path></svg></button></header><div class="organism contentStream"><div><div class="atom photo" itemscope="" itemType="http://schema.org/ImageObject"><p></p><div class="imgWrapper"><img class="atom lazyImage lazy" itemProp="contentUrl" src="https://img.bleacherreport.net/img/images/photos/003/732/006/hi-res-2b08517000d1647d8121cb57c5a92a5a_crop_north.jpg?h=53&amp;w=80&amp;q=70&amp;crop_x=center&amp;crop_y=top" width="800" height="533" alt="BC Prienu Vytautas&#x27;s LiAngelo Ball in action during the Big Baller Brand Challenge friendly tournament match between BC Prienu Vytautas and BC Zalgiris-2 at the BC Prienai-Birstonas Vytautas arena, in Prienai, Lithuania, Tuesday, Jan. 9, 2018. LiAngelo Ball and LaMelo Ball, sons of former basketball player LaVar Ball, have signed a one-year contract and play their first match for Lithuanian professional basketball club Prienu Vytautas. (AP Photo/Liusjenas Kulbis)"/></div><small><span class="caption"></span><span itemProp="citation" class="credit">Liusjenas Kulbis/Associated Press</span></small></div><p><a href="http://bleacherreport.com/liangelo-ball">LiAngelo Ball</a> declared for the 2018 <a href="http://bleacherreport.com/nba">NBA</a> draft Tuesday, according to Ball's agent, Harrison Gaines, per <a href="https://sports.yahoo.com/agent-liangelo-ball-declares-2018-nba-draft-132424934.html" target="_blank" rel="noopener noreferrer">Shams Charania</a><span><span> </span>of Yahoo Sports.</span></p><p>Charania noted Ball has already submitted early-entry paperwork with the NBA.</p><p>After leaving UCLA in December, Ball played alongside his younger brother, LaMelo Ball, for <span>Vytautas Prienu this season in the Lithuanian Basketball League.</span></p><p>After UCLA <a href="http://www.latimes.com/sports/la-sp-ucla-basketball-20171128-story.html" target="_blank" rel="noopener noreferrer">suspended</a> him because of a shoplifting incident in China, Ball signed with Vytautas in January.</p><p>His stay in Lithuania has been productive, as Ball is averaging a league-leading 15.7 points per game while shooting 45 percent from beyond the arc, according to Charania.</p><p>The 19-year-old Ball reportedly plans to take part in May's <span>Pro Basketball Combine at IMG Academy in Bradenton, Florida, in an effort to impress NBA talent evaluators.</span></p><div class="ad"><div class="lazy br-ad-wrapper atom advert"><div id="br-ad-92215508" class="br-ad-lazy" data-collapsed="1" data-position="rect_atf_01" data-reload="1" data-responsive-size="[[[1270,0],[[970,250],[970,66],[300,250]]],[[728,0],[[728,90],[300,250]]],[[0,0],[[300,250],[320,50]]]]" data-size="[[300,600],[300,250],[300,2]]"></div></div></div><p><span>The 6'5" Ball was rated by <a href="https://247sports.com/Player/LiAngelo-Ball-79618/high-school-138262" target="_blank" rel="noopener noreferrer">247Sports</a> as a 3-star prospect coming out of high school, and he was ranked as the No. 226 overall player and No. 50 shooting guard in the 2017 class.</span></p><p><span>Ball will look to follow in the NBA footsteps of his older brother, Lonzo Ball, who plays for the Los Angeles Lakers.</span></p><p><span>In December, ESPN's<span> </span><a href="https://twitter.com/wojespn/status/937816866403229696?ref_src=twsrc%5Etfw&ref_url=https%3A%2F%2F247sports.com%2Fcollege%2Fucla%2FBolt%2FESPN-LiAngelo-Ball-has-no-chance-to-get-drafted-in-2018-111741428" target="_blank" rel="noopener noreferrer">Adrian Wojnarowski</a><span> </span>reported LiAngelo had "no chance" at being selected in the 2018 NBA draft.</span></p></div></div><footer><div class="atom share"><ul><li class="shareFacebook" title="Share this article on Facebook"><svg class="atom svg icon facebook" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 10 16"><title>Facebook Logo</title><path d="M6.24 16V8.7h2.45l.365-2.842H6.24V4.04c0-.822.227-1.384 1.41-1.384h1.5V.112C8.42.035 7.686-.002 6.953 0 4.79 0 3.3 1.325 3.3 3.76v2.098H.846V8.7H3.3V16h2.94z"></path></svg></li><li class="shareTwitter" title="Share this article on Twitter"><svg class="atom svg icon twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 14"><title>Twitter Logo</title><path d="M5.042 13.504c6.01 0 9.3-4.985 9.3-9.3 0-.14 0-.28-.006-.42.638-.46 1.192-1.04 1.632-1.697-.586.262-1.217.434-1.88.517.675-.402 1.192-1.046 1.44-1.81-.63.375-1.332.643-2.078.79C12.85.946 12.003.55 11.066.55c-1.804 0-3.27 1.467-3.27 3.27 0 .256.032.505.083.747-2.717-.134-5.126-1.44-6.74-3.417C.86 1.635.7 2.196.7 2.795c0 1.134.58 2.135 1.455 2.722-.536-.02-1.04-.166-1.48-.408v.043c0 1.58 1.13 2.907 2.62 3.207-.273.076-.56.115-.86.115-.21 0-.414-.02-.612-.058.414 1.3 1.626 2.244 3.053 2.27-1.12.88-2.53 1.402-4.06 1.402-.26 0-.523-.014-.778-.046 1.44.918 3.162 1.46 5.004 1.46"></path></svg></li><li class="shareLink" title="Copy this link to your clipboard"><svg class="atom svg icon link" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20 10"><title>Copy Link Icon</title><path d="M1.9 5c0-1.71 1.39-3.1 3.1-3.1h4V0H5C2.24 0 0 2.24 0 5s2.24 5 5 5h4V8.1H5C3.29 8.1 1.9 6.71 1.9 5zM6 6h8V4H6v2zm9-6h-4v1.9h4c1.71 0 3.1 1.39 3.1 3.1 0 1.71-1.39 3.1-3.1 3.1h-4V10h4c2.76 0 5-2.24 5-5s-2.24-5-5-5z"></path></svg></li></ul></div><div class="atom facebookComments"><button type="button" class="atom button">Comments<!-- --> <svg class="atom svg icon downArrow" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 15 9"><title>Down Arrow Icon</title><g><polygon transform="translate(7.500000, 4.366471) scale(-1, 1) rotate(-90.000000) translate(-7.500000, -4.366471) " points="10.2924859 -3.13352866 3.13352866 4.36647134 10.2924859 11.8664713 11.8664713 9.94254375 6.54395614 4.36647134 11.8664713 -1.20960107"></polygon></g></svg></button><div class="fb-comments" data-width="100%" data-href="http://bleacherreport.com/articles/2766836"></div></div></footer><div class="atom relatedContent offscreen"><div class="organism contentStream"><h1>Related</h1><ol><div class="cell articleSummary" data-article-id="6464924063"><div class="atom commentary"><h3>Hawks, Budenholzer Agree to Part Ways</h3></div><div class="articleMedia"><a href="http://bleacherreport.com/articles/2759709-mike-budenholzer-reportedly-parts-ways-with-hawks-after-5-seasons" class="molecule thumbnailImage" data-photo="" target="_self" rel="noopener"><img class="atom lazyImage lazy" itemProp="contentUrl" src="https://img.bleacherreport.net/cms/media/image/77/75/f0/a9/505a/4780/a54c/166c38b205eb/crop_exact_944466966.jpg?h=20&amp;w=30&amp;q=70&amp;crop_x=center&amp;crop_y=top" width="300" height="200" alt=""/></a></div><div class="articleContent"><a class="atom teamAvatar" href="/nba"><div class="imgWrapper"><img src="https://cdn.bleacherreport.net/images/team_logos/328x328/nba.png" alt="NBA logo"/></div><span>NBA</span></a><a class="atom articleTitle" href="http://bleacherreport.com/articles/2759709-mike-budenholzer-reportedly-parts-ways-with-hawks-after-5-seasons" target="_self" rel="noopener"><h3>Hawks, Budenholzer Agree to Part Ways</h3></a><span class="atom authorInfo"><a class="authorPhoto" href="/users/undefined"><svg class="atom svg icon defaultUser" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 100 100"><circle cx="50" cy="50" r="50"></circle><g fill="#FFF" transform="translate(20 15)"><path d="M0 60.617C7.165 69.407 17.945 75 30 75s22.835-5.593 30-14.383C54.197 51.31 42.938 45 30 45 17.062 45 5.803 51.31 0 60.617z"></path><circle cx="30" cy="20" r="20"></circle></g></svg></a><a href="/users/undefined" rel="noopener noreferrer"><span class="name">Rob Goldberg</span></a></span></div><span class="provider">via Bleacher Report</span></div><div class="cell articleSummary" data-article-id="6464857405"><div class="atom commentary"><h3>Process or Die Merch Is Here — Join the Movement 🙏</h3></div><div class="articleMedia"><a href="http://www.processordie.com/" class="molecule thumbnailImage" data-photo="" target="_blank" rel="noopener"><img class="atom lazyImage lazy" itemProp="contentUrl" src="https://img.bleacherreport.net/cms/media/image/28/47/97/5c/2fe2/4138/a098/9b31332ed397/crop_exact_placeit_1024.jpg?h=20&amp;w=30&amp;q=70&amp;crop_x=center&amp;crop_y=top" width="300" height="200" alt=""/></a></div><div class="articleContent"><a class="atom teamAvatar" href="/nba"><div class="imgWrapper"><img src="https://cdn.bleacherreport.net/images/team_logos/328x328/nba.png" alt="NBA logo"/></div><span>NBA</span></a><a class="atom articleTitle" href="http://www.processordie.com/" target="_blank" rel="noopener"><h3>Process or Die Merch Is Here — Join the Movement 🙏</h3></a><span class="atom authorInfo"><a class="authorPhoto" href="/users/undefined"><svg class="atom svg icon defaultUser" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 100 100"><circle cx="50" cy="50" r="50"></circle><g fill="#FFF" transform="translate(20 15)"><path d="M0 60.617C7.165 69.407 17.945 75 30 75s22.835-5.593 30-14.383C54.197 51.31 42.938 45 30 45 17.062 45 5.803 51.31 0 60.617z"></path><circle cx="30" cy="20" r="20"></circle></g></svg></a><a href="/users/undefined" rel="noopener noreferrer"><span class="name">Process, or D.I.E.</span></a></span></div><span class="provider">via Process, or D.I.E.</span></div><div class="cell articleSummary" data-article-id="6464912046"><div class="atom commentary"><h3>LeBron Drops 44, Sinks Game-Winner to Beat Pacers</h3></div><div class="articleMedia"><a href="http://bleacherreport.com/articles/2772578-lebron-james-buzzer-beater-powers-cavaliers-past-pacers-in-game-5-win" class="molecule thumbnailImage" data-photo="" target="_self" rel="noopener"><img class="atom lazyImage lazy" itemProp="contentUrl" src="https://img.bleacherreport.net/cms/media/image/d2/a9/b9/d1/70ee/4800/8df4/41831f4b9bb7/crop_exact_GettyImages-951290264.jpg?h=20&amp;w=30&amp;q=70&amp;crop_x=center&amp;crop_y=top" width="300" height="200" alt=""/></a></div><div class="articleContent"><a class="atom teamAvatar" href="/nba"><div class="imgWrapper"><img src="https://cdn.bleacherreport.net/images/team_logos/328x328/nba.png" alt="NBA logo"/></div><span>NBA</span></a><a class="atom articleTitle" href="http://bleacherreport.com/articles/2772578-lebron-james-buzzer-beater-powers-cavaliers-past-pacers-in-game-5-win" target="_self" rel="noopener"><h3>LeBron Drops 44, Sinks Game-Winner to Beat Pacers</h3></a><span class="atom authorInfo"><a class="authorPhoto" href="/users/undefined"><svg class="atom svg icon defaultUser" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 100 100"><circle cx="50" cy="50" r="50"></circle><g fill="#FFF" transform="translate(20 15)"><path d="M0 60.617C7.165 69.407 17.945 75 30 75s22.835-5.593 30-14.383C54.197 51.31 42.938 45 30 45 17.062 45 5.803 51.31 0 60.617z"></path><circle cx="30" cy="20" r="20"></circle></g></svg></a><a href="/users/undefined" rel="noopener noreferrer"><span class="name">Alec Nathan</span></a></span></div><span class="provider">via Bleacher Report</span></div><div class="cell articleSummary" data-article-id="6464875508"><div class="atom commentary"><h3>Bold Predictions for Free Agency</h3></div><div class="articleMedia"><a href="http://bleacherreport.com/articles/2772064-6-bold-predictions-for-2018-nba-free-agency" class="molecule thumbnailImage" data-photo="" target="_self" rel="noopener"><img class="atom lazyImage lazy" itemProp="contentUrl" src="https://img.bleacherreport.net/cms/media/image/6c/48/ce/e9/5b80/4e2b/a234/9773bcf0a538/crop_exact_AP_17351005679327.jpg?h=20&amp;w=30&amp;q=70&amp;crop_x=center&amp;crop_y=top" width="300" height="200" alt=""/></a></div><div class="articleContent"><a class="atom teamAvatar" href="/nba"><div class="imgWrapper"><img src="https://cdn.bleacherreport.net/images/team_logos/328x328/nba.png" alt="NBA logo"/></div><span>NBA</span></a><a class="atom articleTitle" href="http://bleacherreport.com/articles/2772064-6-bold-predictions-for-2018-nba-free-agency" target="_self" rel="noopener"><h3>Bold Predictions for Free Agency</h3></a><span class="atom authorInfo"><a class="authorPhoto" href="/users/undefined"><svg class="atom svg icon defaultUser" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 100 100"><circle cx="50" cy="50" r="50"></circle><g fill="#FFF" transform="translate(20 15)"><path d="M0 60.617C7.165 69.407 17.945 75 30 75s22.835-5.593 30-14.383C54.197 51.31 42.938 45 30 45 17.062 45 5.803 51.31 0 60.617z"></path><circle cx="30" cy="20" r="20"></circle></g></svg></a><a href="/users/undefined" rel="noopener noreferrer"><span class="name">Grant Hughes</span></a></span></div><span class="provider">via Bleacher Report</span></div></ol></div></div><div class="atom outbrain OUTBRAIN" data-src="http://bleacherreport.com/articles/2766836" data-widget-id="AR_8" data-ob-template="BleacherReport_1"></div></article></div><div class="adsContainer"><div></div></div><footer class="molecule footer"><div><ul class="social"><li><a href="https://facebook.com/bleacherreport"><svg class="atom svg icon facebookFilled" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 267 267"><title>Facebook Logo</title><path d="M252.16,0H14.73A14.73,14.73,0,0,0,0,14.73V252.16a14.73,14.73,0,0,0,14.73,14.73H142.56V163.54H107.78V123.26h34.78V93.55c0-34.47,21.05-53.24,51.81-53.24a285.37,285.37,0,0,1,31.08,1.59v36H204.12c-16.72,0-20,7.95-20,19.61v25.72H224l-5.19,40.28H184.15V266.89h68a14.73,14.73,0,0,0,14.73-14.73V14.73A14.73,14.73,0,0,0,252.16,0Z"></path></svg></a></li><li><a href="https://twitter.com/bleacherreport"><svg class="atom svg icon twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 14"><title>Twitter Logo</title><path d="M5.042 13.504c6.01 0 9.3-4.985 9.3-9.3 0-.14 0-.28-.006-.42.638-.46 1.192-1.04 1.632-1.697-.586.262-1.217.434-1.88.517.675-.402 1.192-1.046 1.44-1.81-.63.375-1.332.643-2.078.79C12.85.946 12.003.55 11.066.55c-1.804 0-3.27 1.467-3.27 3.27 0 .256.032.505.083.747-2.717-.134-5.126-1.44-6.74-3.417C.86 1.635.7 2.196.7 2.795c0 1.134.58 2.135 1.455 2.722-.536-.02-1.04-.166-1.48-.408v.043c0 1.58 1.13 2.907 2.62 3.207-.273.076-.56.115-.86.115-.21 0-.414-.02-.612-.058.414 1.3 1.626 2.244 3.053 2.27-1.12.88-2.53 1.402-4.06 1.402-.26 0-.523-.014-.778-.046 1.44.918 3.162 1.46 5.004 1.46"></path></svg></a></li><li><a href="https://instagram.com/bleacherreport/"><svg class="atom svg icon instagram" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><title>Instagram Logo</title><g><path d="M11.816 5.744c-3.353 0-6.072 2.72-6.072 6.072 0 3.353 2.72 6.072 6.072 6.072 3.353 0 6.072-2.72 6.072-6.072 0-1.61-.64-3.155-1.778-4.294-1.14-1.138-2.684-1.778-4.294-1.778zm0 10.016c-2.178 0-3.944-1.766-3.944-3.944s1.766-3.944 3.944-3.944 3.944 1.766 3.944 3.944-1.766 3.944-3.944 3.944z"></path><circle cx="18.128" cy="5.52" r="1.416"></circle><path d="M23.024 4.08c-.614-1.587-1.87-2.842-3.456-3.456-.92-.345-1.89-.532-2.872-.552C15.432.016 15.032 0 11.824 0S8.208 0 6.952.072C5.97.092 5 .28 4.08.624 2.493 1.238 1.238 2.494.624 4.08.28 5 .092 5.97.072 6.952.016 8.216 0 8.616 0 11.824s0 3.616.072 4.872c.02.982.207 1.953.552 2.872.614 1.587 1.87 2.842 3.456 3.456.917.36 1.888.56 2.872.592 1.264.056 1.664.072 4.872.072s3.616 0 4.872-.072c.982-.02 1.953-.207 2.872-.552 1.587-.614 2.842-1.87 3.456-3.456.345-.92.532-1.89.552-2.872.056-1.264.072-1.664.072-4.872s0-3.616-.072-4.872c-.016-.995-.202-1.98-.552-2.912zm-1.6 12.52c-.007.757-.145 1.506-.408 2.216-.398 1.033-1.215 1.85-2.248 2.248-.702.26-1.443.398-2.192.408-1.248.056-1.6.072-4.8.072-3.2 0-3.528 0-4.8-.072-.75-.01-1.49-.148-2.192-.408-1.037-.395-1.857-1.213-2.256-2.248-.26-.702-.398-1.443-.408-2.192-.056-1.248-.072-1.6-.072-4.8 0-3.2 0-3.528.072-4.8.007-.757.145-1.506.408-2.216.4-1.035 1.22-1.853 2.256-2.248.702-.26 1.443-.398 2.192-.408 1.248-.056 1.6-.072 4.8-.072 3.2 0 3.528 0 4.8.072.75.01 1.49.148 2.192.408 1.033.398 1.85 1.215 2.248 2.248.26.702.398 1.443.408 2.192.056 1.248.072 1.6.072 4.8 0 3.2 0 3.544-.056 4.8h-.016z"></path></g></svg></a></li></ul><ul class="links"><li><a href="/about">About</a></li><li><a href="/advertise">Advertise</a></li><li><a href="http://blog.bleacherreport.com">Blog</a></li><li><a href="/contact">Contact Us</a></li><li><a href="/careers">Careers</a></li><li><a href="/pages/comguidelines">Community Guidelines</a></li><li><a href="/press-room">Press</a></li><li><a href="/pages/privacy">Privacy</a></li><li><a href="/pages/terms">Terms Of Use</a></li><li><a href="https://www.stubhub.com/?gcid=chAFF-_-geoUS-_-genAllTix-_-dt170312-_-cmpBR_footr-_-partBleacherReport">Tickets</a></li><li><a href="#">AdChoices <img src="https://static-assets.bleacherreport.com/img/molecules/footer/adChoices.png" width="12" height="12" alt="" role="presentation" style="vertical-align:middle"/></a></li></ul></div><svg class="atom svg logo brPlateLight" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 1600 1200"><title>Bleacher Report Logo</title><g><rect width="1600" height="1200" fill="#fff"></rect><path fill="#000" d="M484.85 200H200v800h284.85L600 884.85v-229.7L544.85 600 600 544.85v-229.7zM320 540V320h115.15L480 364.85v130.3L435.15 540zm115.15 120L480 704.85v130.3L435.15 880H320V660zM1415 1000l-99.35-370.79 84.35-84.36v-229.7L1284.85 200H1000v800h120V660h83.9l91.1 340zm-295-680h115.15l44.85 44.85v130.3L1235.15 540H1120zM700 770.71l200-200V429.29l-200 200v141.42z"></path></g></svg><small class="copyright">
	Copyright © 2018 Bleacher Report, Inc. Turner Broadcasting System, Inc.
	All Rights Reserved.
	BleacherReport.com is part of Bleacher Report – Turner Sports Network, part of the Turner Sports and Entertainment Network.
<!-- -->
	Certain photos copyright © 2018 Getty Images.
	Any commercial use or distribution without the express written consent of Getty Images is strictly prohibited.
<a href="#">AdChoices <img src="https://static-assets.bleacherreport.com/img/molecules/footer/adChoices.png" width="12" height="12" alt="" role="presentation" style="vertical-align:middle"/></a></small><svg class="atom svg logo turner" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 601.7 105.2"><title>Turner Logo</title><path d="M502.3 63.5c1.7-7.2 2.7-13.3 2.7-19.3C505 19.6 488.5.1 460.5.1 430 .1 405.7 22.9 401 52.6c-5 31.5 14.3 52.5 44.2 52.5 23.6 0 43.5-13.3 53.7-33.5h-36.1c-4.5 4.7-10.5 6-15.7 5.9-10.4-.2-15.3-6.3-15.4-14h70.6zm-43.7-36.9c9.2 0 15.4 5.8 15.1 14.5h-37c3.5-8.5 11.8-14.5 21.9-14.5zM579 .6c-12.5 0-22.8 10.2-22.8 22.6 0 12.6 10.3 22.9 22.8 22.9 12.6 0 22.9-10.3 22.7-22.9C601.9 10.7 591.6.6 579 .6zM364.9 0c-11.4 0-25.3 6.9-32 16l3.8-13.4h-32.4l-17.7 100.2h34.8l10-56.7c1.7-9.4 9-15.9 17.7-15.9 8.4 0 12.4 6.9 10.9 15.9l-10 56.7h34.8l10.9-61.5C400.1 16 387.8 0 364.9 0zM5.7 2.6h91.6l-5.7 32.2H63.8l-12 67.9H17l12-67.9H0M105.3 2.6h34.8l-9.8 55.7c-1.7 9.6 2.7 15.3 11.2 15.3 8.7 0 15.5-6 17.2-15.3l9.8-55.7h34.8L193.9 56c-6 33.4-27.7 49-56.9 49-29.8 0-46.9-16.3-41.1-49.2l9.4-53.2zM194.6 102.7h34.7L247 2.6h-34.8M270.2.6c-12.4 0-22.8 10.2-22.8 22.6 0 12.6 10.3 22.9 22.8 22.9 12.6 0 22.9-10.3 22.8-22.9.1-12.5-10.2-22.6-22.8-22.6zM503.3 102.7H538L555.7 2.6h-34.8"></path></svg></footer></div></div></div><script src="https://static-assets.bleacherreport.com/js/bundle.afba81e2767d580954ee4c889ff54945.js" async="" defer="" id=""></script><div id="analytics-nielsen"><img src="https://secure-us.imrworldwide.com/cgi-bin/m?ci=us-204044h&amp;cg=0&amp;cc=1&amp;ts=compact&amp;rnd=1524709799547" width="1" height="1" alt=""/><noscript><img src="https://secure-us.imrworldwide.com/cgi-bin/m?ci=us-204044h&amp;cg=0&amp;cc=1&amp;ts=noscript" width="1" height="1" alt=""/></noscript></div><div id="pixels"></div><div><!-- Generated on 04/26/18 at 02:29 AM --></div></body></html>